diff mbox series

[bug#52696,12/12] gnu: orange: Update to 3.31.0.

Message ID 20211221044643.78959-12-monego@posteo.net
State Accepted
Headers show
Series Update Orange. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Dec. 21, 2021, 4:46 a.m. UTC
* gnu/packages/orange.scm (orange): Update to 3.31.0.
[arguments]<#:phases>: Don't return #t. Adjust file name for substitution in
'preparations. Rename 'set-HOME to 'pre-check. Set QT_QPA_PLATFORM in
'pre-check.
[inputs]: Add python-pygments, python-qtconsole.
---
 gnu/packages/orange.scm | 18 ++++++++++--------
 1 file changed, 10 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/orange.scm b/gnu/packages/orange.scm
index 710be87cb0..34d181d222 100644
--- a/gnu/packages/orange.scm
+++ b/gnu/packages/orange.scm
@@ -102,13 +102,13 @@  GUI based workflow.  It is primarily used in the Orange framework.")
 (define-public orange
   (package
     (name "orange")
-    (version "3.28.0")
+    (version "3.31.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Orange3" version))
        (sha256
-        (base32 "1ac4xjjkx06z10hl7k0zh1z3qhkl5vng15l9jkpkmck9spinbzil"))))
+        (base32 "15xf7v9kc9gz6j9h709168hxq9kdszk49l8c9ic70fgfn2c4rndk"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -125,11 +125,12 @@  GUI based workflow.  It is primarily used in the Orange framework.")
              ;; We use a correct version of PyQtWebEngine, but the build scripts
              ;; consider it incorrect anyways. Remove the constraint entirely to
              ;; work around this bug.
-             (substitute* "requirements-gui.txt" (("PyQtWebEngine>=5.12") ""))
-             #t))
-         (add-before 'check 'set-HOME
+             (substitute* "requirements-pyqt.txt" (("PyQtWebEngine>=5.12") ""))))
+         (add-before 'check 'pre-check
            ;; Tests need a writable home.
-           (lambda _ (setenv "HOME" "/tmp") #t))
+           (lambda _
+             (setenv "HOME" "/tmp")
+             (setenv "QT_QPA_PLATFORM" "offscreen")))
          (add-after 'install 'wrap-executable
            ;; Ensure that icons are found at runtime.
            (lambda* (#:key inputs outputs #:allow-other-keys)
@@ -137,8 +138,7 @@  GUI based workflow.  It is primarily used in the Orange framework.")
                (wrap-program (string-append out "/bin/orange-canvas")
                  `("QT_PLUGIN_PATH" prefix
                    ,(list (string-append (assoc-ref inputs "qtsvg")
-                                         "/lib/qt5/plugins/")))))
-             #t)))))
+                                         "/lib/qt5/plugins/"))))))))))
     (native-inputs
      (list python-cython))
     (inputs
@@ -159,10 +159,12 @@  GUI based workflow.  It is primarily used in the Orange framework.")
            python-orange-canvas-core
            python-orange-widget-base
            python-pandas
+           python-pygments
            python-pyqt
            python-pyqtgraph
            python-pyqtwebengine
            python-pyyaml
+           python-qtconsole
            python-requests
            python-scikit-learn
            python-scipy