diff mbox series

[bug#52247,v2,2/2] gnu: shotcut: Adjust environment variables in 'wrap-program.

Message ID 20211218181227.82026-2-monego@posteo.net
State Accepted
Headers show
Series [bug#52247,v2,1/2] gnu: shotcut: Find ffmpeg and mlt at runtime. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Dec. 18, 2021, 6:12 p.m. UTC
* gnu/packages/video.scm (shotcut)[arguments]<#:phases>: In the 'wrap-program
phase, wrap LADSPA_PATH, don't wrap MLT_PREFIX, remove trailing slash from
FREI0R_PATH, remove ffmpeg and add mlt to PATH.
---
 gnu/packages/video.scm | 15 ++++++++-------
 1 file changed, 8 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 9b5738358b..30d6341c59 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4844,18 +4844,19 @@  transitions, and effects and then export your film to many common formats.")
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (frei0r (assoc-ref inputs "frei0r-plugins"))
-                    (ffmpeg (assoc-ref inputs "ffmpeg"))
                     (jack (assoc-ref inputs "jack"))
+                    (ladspa (assoc-ref inputs "ladspa"))
+                    (mlt (assoc-ref inputs "mlt"))
                     (sdl2 (assoc-ref inputs "sdl2")))
                (wrap-program (string-append out "/bin/shotcut")
-                 `("PATH" ":" prefix
-                   ,(list (string-append ffmpeg "/bin")))
+                 `("FREI0R_PATH" ":" =
+                   (,(string-append frei0r "/lib/frei0r-1")))
+                 `("LADSPA_PATH" ":" =
+                   (,(string-append ladspa "/lib/ladspa")))
                  `("LD_LIBRARY_PATH" ":" prefix
                    ,(list (string-append jack "/lib" ":" sdl2 "/lib")))
-                 `("FREI0R_PATH" ":" =
-                   (,(string-append frei0r "/lib/frei0r-1/")))
-                 `("MLT_PREFIX" ":" =
-                   (,(assoc-ref inputs "mlt"))))))))))
+                 `("PATH" ":" prefix
+                   ,(list (string-append mlt "/bin"))))))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("python" ,python-wrapper)