diff mbox series

[bug#48289] gnu: Add python-pythonanywhere.

Message ID 20211217230847.9375-1-filip@lajszczak.dev
State Accepted
Headers show
Series [bug#48289] gnu: Add python-pythonanywhere. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Filip Lajszczak Dec. 17, 2021, 11:08 p.m. UTC
* gnu/packages/python-xyz.scm (python-pythonanywhere): New variable.
---
 gnu/packages/python-xyz.scm | 49 +++++++++++++++++++++++++++++++++++++
 1 file changed, 49 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2af4794..2c319a0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -112,6 +112,7 @@ 
 ;;; Copyright © 2021 Sébastien Lerique <sl@eauchat.org>
 ;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
 ;;; Copyright © 2021 ZmnSCPxj <ZmnSCPxj@protonmail.com>
+;;; Copyright © 2021 Filip Lajszczak <filip@lajszczak.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -12406,6 +12407,54 @@  (define-public python-docopt
 (define-public python2-docopt
   (package-with-python2 python-docopt))
 
+(define-public python-pythonanywhere
+  (package
+    (name "python-pythonanywhere")
+    (version "0.9.10")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/pythonanywhere/helper_scripts")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+           "0vzzc1g8pl7cb9yvm3n1j5zlzxf0jd423rzspc2kvpb8yhvydklx"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'change-home
+           (lambda _
+             (setenv "HOME" "/tmp")))
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+                    (when tests?
+                      ;; exclude tests marked as slowtest that assume running
+                      ;; inside git repository on system with virtualenvwrapper
+                      ;; installed.
+                      (invoke "pytest" "-m" "not slowtest")))))))
+    (native-inputs
+      (list python-pytest
+            python-psutil
+            python-responses
+            python-pytest-mock))
+    (propagated-inputs
+      (list python-dateutil
+            python-docopt
+            python-packaging
+            python-requests
+            python-schema
+            python-tabulate
+            python-typer))
+    (home-page "https://github.com/pythonanywhere/helper_scripts/")
+    (synopsis "PythonAnywhere helper tools for users")
+    (description "PythonAnywhere helper tools for users.  Cli and python wrapper
+around API that allows managing web apps and scheduled tasks.  Includes single-command
+deployment for Django Girls tutorial.")
+    (license license:expat)))
+
 (define-public python-pythondialog
   (package
     (name "python-pythondialog")