diff mbox series

[bug#52492,3/7] gnu: Add wireplumber

Message ID 20211214214752.25096-3-dev@jpoiret.xyz
State Accepted
Headers show
Series Improve screen sharing support under Wayland | expand

Commit Message

Josselin Poiret Dec. 14, 2021, 9:47 p.m. UTC
* gnu/packages/linux.scm (wireplumber): Add it.
---
 gnu/packages/linux.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Mathieu Othacehe Dec. 19, 2021, 12:24 p.m. UTC | #1
> +    (native-inputs
> +     `(("glib-bin" ,glib "bin")
> +       ("pkg-config" ,pkg-config)))

I replaced it to use the new style.

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 77632c51c9..ec41a5450b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -88,6 +88,7 @@  (define-module (gnu packages linux)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
+  #:use-module (gnu packages build-tools)
   #:use-module (gnu packages calendar)
   #:use-module (gnu packages check)
   #:use-module (gnu packages cpio)
@@ -8143,6 +8144,36 @@  (define-public pipewire-0.3
                        vulkan-loader
                        vulkan-headers)))))
 
+(define-public wireplumber
+  (package
+    (name "wireplumber")
+    (version "0.4.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url
+                     "https://gitlab.freedesktop.org/pipewire/wireplumber.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1k56i5cardwr03vkldg68714hyksyp1vb0b315yw1bilaj2ka30i"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:configure-flags '("-Dsystemd=disabled"
+                           "-Dsystem-lua=true")))
+    (native-inputs
+     `(("glib-bin" ,glib "bin")
+       ("pkg-config" ,pkg-config)))
+    (inputs (list dbus elogind glib lua pipewire-0.3))
+    (home-page "https://gitlab.freedesktop.org/pipewire/wireplumber")
+    (synopsis "Session / policy manager implementation for PipeWire")
+    (description "WirePlumber is a modular session / policy manager for
+PipeWire and a GObject-based high-level library that wraps PipeWire's API,
+providing convenience for writing the daemon's modules as well as external
+tools for managing PipeWire.")
+    (license license:expat)))
+
 (define-public ell
   (package
     (name "ell")