diff mbox series

[bug#52486,v2,1/2] gnu: deluge: Move librsvg to native inputs

Message ID 20211214191713.18665-2-dev@jpoiret.xyz
State Accepted
Headers show
Series Fix deluge propagating a librsvg incompatible with that of gtk+ | expand

Commit Message

Josselin Poiret Dec. 14, 2021, 7:17 p.m. UTC
* gnu/packages/bittorrent.scm (deluge): Do it.
---
 gnu/packages/bittorrent.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 0dcb1ee991..6c6d01991a 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -528,7 +528,6 @@  (define-public deluge
     (build-system python-build-system)
     (propagated-inputs
      `(("gtk+" ,gtk+)
-       ("librsvg" ,librsvg)
        ("libtorrent" ,libtorrent-rasterbar)
        ("python-pycairo" ,python-pycairo)
        ("python-chardet" ,python-chardet)
@@ -545,7 +544,10 @@  (define-public deluge
        ("python-twisted" ,python-twisted)
        ("python-zope-interface" ,python-zope-interface)))
     (native-inputs
-     (list intltool python-wheel))
+     (list intltool python-wheel
+           (if (string-prefix? "x86_64-" (%current-system))
+               librsvg-bootstrap
+               librsvg-2.40)))
     ;; TODO: Enable tests.
     ;; After "pytest-twisted" is packaged, HOME is set, and an X server is
     ;; started, some of the tests still fail.  There are likely some tests