diff mbox series

[bug#52463] gnu: Add r-chromvarmotifs.

Message ID 20211213115207.14186-1-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#52463] gnu: Add r-chromvarmotifs. | expand

Commit Message

Mădălin Ionel Patrașcu Dec. 13, 2021, 11:52 a.m. UTC
* gnu/packages/bioconductor.scm (r-chromvarmotifs): New variable.
This package is not a bioconductor one, but it use the r-tfbstools
that is stored in bioconductor.scm.  If I used the cran.scm for the
current definition I should import the bioconductor and it already
imports cran.  Beside this the package is somehow related with other
bioconductor packages.
---
 gnu/packages/bioconductor.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Ricardo Wurmus Dec. 13, 2021, 12:38 p.m. UTC | #1
Applied to the “master” branch with commit
5f32468acfc7ae3a7dd736810ab0c3cdde7310da.  Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 44bf5c7d24..28cc8b7458 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1183,6 +1183,35 @@  (define-public r-chromstardata
 chromstaR package.")
     (license license:gpl3)))
 
+(define-public r-chromvarmotifs
+  (let
+      ((commit "38bed559c1f4770b6c91c80bf3f8ea965da26076")
+       (revision "1"))
+    (package
+      (name "r-chromvarmotifs")
+      (version (git-version "0.2.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/GreenleafLab/chromVARmotifs")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0i9v1m1hrg1lkd2pnkj5nnrpks6vhhhpbdhsfl2lmjak4npxxr5q"))))
+      (properties `((upstream-name . "chromVARmotifs")))
+      (build-system r-build-system)
+      (propagated-inputs
+       `(("r-tfbstools" ,r-tfbstools)))
+      (home-page "https://github.com/GreenleafLab/chromVARmotifs")
+      (synopsis "Stores motif collections for use with motifmatchr or chromVAR")
+      (description
+       "This package @code{r-chromvarmotifs} stores motifs collections as
+lists of @dfn{position frequency matrix} (PWMatrixList) objects provided by
+@code{TFBSTools} package for use in R with packages like @code{motifmatchr} or
+@code{chromVAR}.")
+      (license license:expat))))
+
 (define-public r-copyhelper
   (package
     (name "r-copyhelper")