diff mbox series

[bug#51838,v3,12/43] gnu: node-llparse-frontend-bootstrap: Use #:absent-dependencies.

Message ID 20211208202838.752542-13-philip@philipmcgrath.com
State Accepted
Headers show
Series guix: node-build-system: Support compiling add-ons with node-gyp. | expand

Commit Message

Philip McGrath Dec. 8, 2021, 8:28 p.m. UTC
gnu/packages/node.scm (node-llparse-frontend-bootstrap)[arguments]: Add
`#:absent-dependencies`. Stop deleting the `'configure` phase.
---
 gnu/packages/node.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 9d4903a8ca..298b9376a8 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -547,9 +547,16 @@  (define-public node-llparse-frontend-bootstrap
     (arguments
      `(#:node ,node-bootstrap
        #:tests? #f
+       #:absent-dependencies
+       `("@types/debug"
+         "@types/mocha"
+         "@types/node"
+         "mocha"
+         "ts-node"
+         "tslint"
+         "typescript")
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure)
          (replace 'build
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((esbuild (string-append (assoc-ref inputs "esbuild")