diff mbox series

[bug#51838,v3,09/43] gnu: node-binary-search-bootstrap: Use #:absent-dependencies.

Message ID 20211208202838.752542-10-philip@philipmcgrath.com
State Accepted
Headers show
Series guix: node-build-system: Support compiling add-ons with node-gyp. | expand

Commit Message

Philip McGrath Dec. 8, 2021, 8:28 p.m. UTC
gnu/packages/node.scm (node-binary-search-bootstrap)[arguments]: Add
`#:absent-dependencies`. Stop deleting the `'configure` phase.
---
 gnu/packages/node.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index ca4bf1ad23..2cdae34ae1 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -389,9 +389,9 @@  (define-public node-binary-search-bootstrap
     (arguments
      `(#:node ,node-bootstrap
        #:tests? #f
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure))))
+       #:absent-dependencies
+       `("chai"
+         "mocha")))
     (home-page "https://github.com/darkskyapp/binary-search#readme")
     (properties '((hidden? . #t)))
     (synopsis "Tiny binary search function with comparators")