diff mbox series

[bug#52177,v2] gnu: Add pudb.

Message ID 20211203074449.21071-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#52177,v2] gnu: Add pudb. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

jgart Dec. 3, 2021, 7:44 a.m. UTC
This patch version just updates the python-pygments propagated-input to
not use the fixed variable.

all best,

jgart

* gnu/packages/python-xyz.scm (pudb): New variable.
---
 gnu/packages/python-xyz.scm | 39 +++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

Comments

Nicolas Goaziou Dec. 5, 2021, 11:19 a.m. UTC | #1
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> This patch version just updates the python-pygments propagated-input to
> not use the fixed variable.

I fixed indentation and pushed. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b7fff3cd89..0c9e28c2da 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28088,6 +28088,45 @@  (define-public python-sgmllib3k
 Mark-up Language}.")
     (license license:bsd-3)))
 
+(define-public pudb
+  (package
+    (name "pudb")
+    (version "2021.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "pudb" version))
+        (sha256
+          (base32 "0p16pvzfa3w02ybg3n0iy5rs23z4rz4a42lb8wh3mcq62y9ik2w7"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'fix-read-only-home
+           (lambda _
+             (setenv "HOME" "/tmp")))
+         (replace 'check
+             (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+               (when tests?
+                 (add-installed-pythonpath inputs outputs)
+                 (invoke "pytest")))))))
+    (native-inputs
+      `(("python-numpy" ,python-numpy)
+        ("python-pytest" ,python-pytest)
+        ("python-pytest-mock" ,python-pytest-mock)))
+    (propagated-inputs
+      `(("python-jedi" ,python-jedi)
+        ("python-pygments" ,python-pygments)
+        ("python-urwid" ,python-urwid)
+        ("python-urwid-readline" ,python-urwid-readline)))
+    (home-page "https://documen.tician.de/pudb/")
+    (synopsis "Console-based Python debugger")
+    (description
+"@command{pudb} is a full-screen, console-based Python debugger
+providing all the niceties of modern GUI-based debuggers in a more
+lightweight and keyboard-friendly package.")
+    (license license:expat)))
+
 (define-public python-iwlib
   (package
     (name "python-iwlib")