diff mbox series

[bug#52186,core-updates-frozen,v2,14/17] gnu: julia-mutablearithmetics: Fix tests on i686-linux.

Message ID 20211201155442.60916-5-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#52186,core-updates-frozen,v2,01/17] gnu: libunwind-julia: Fix build on i686-linux. | expand

Commit Message

Simon Tournier Dec. 1, 2021, 3:54 p.m. UTC
* gnu/packages/julia-xyz.scm (julia-mutablearithmetics)[arguments]<#:phases>:
Conditionally disable the failing test.
---
 gnu/packages/julia-xyz.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 14012a3c3b..363e7b5f11 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3241,6 +3241,23 @@  (define-public julia-mutablearithmetics
         (sha256
          (base32 "1isyj8h4nx96cr6892d154v8pw1nhr7mjyz5bd6ffr2mkzb2bq4f"))))
     (build-system julia-build-system)
+    (arguments
+     `(#:phases
+       ,@(if (string-prefix? "i686" (or (%current-target-system)
+                                        (%current-system)))
+             '((modify-phases %standard-phases
+                 (add-after 'unpack 'remove-failing-test-i686
+                   (lambda _
+                     (substitute* "test/utilities.jl"
+                       ;; Non-deterministic returned value, e.g.,
+                       ;;    Expression: n == @allocated(f())
+                       ;;    Evaluated: 240 == 120
+                       ;; and for some other values:
+                       ;;    Got correct result, please change to @test
+                       ;; so @test_broken is not enough.
+                       (("@test n == @allocated f\\(\\)")
+                        " "))))))
+             '(%standard-phases))))
     (propagated-inputs
      `(("julia-offsetarrays" ,julia-offsetarrays)))
     (home-page "https://github.com/jump-dev/MutableArithmetics.jl")