diff mbox series

[bug#52211,v2] gnu: Add julia-softglobalscope.

Message ID 20211201015645.8018-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#52211,v2] gnu: Add julia-softglobalscope. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

jgart Dec. 1, 2021, 1:56 a.m. UTC
Hi Guixers,

I forgot to add a copyright statement.

all best,

jgart

* gnu/packages/julay-xyz.scm (julia-softglobalscope): New variable.
---
 gnu/packages/julia-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Efraim Flashner Dec. 1, 2021, 12:09 p.m. UTC | #1
I resorted this one alphabetically and pushed it. Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 547d2bf81e..68284fbf46 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4972,6 +4973,29 @@  (define-public julia-zygoterules
 Zygote, without depending on Zygote itself.")
     (license license:expat)))
 
+(define-public julia-softglobalscope
+  (package
+    (name "julia-softglobalscope")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/stevengj/SoftGlobalScope.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1n3l0al1vw5jpb4k9a29a71666cdb617nmiqg34wcmyfzrxpvv39"))))
+    (build-system julia-build-system)
+    (home-page "https://github.com/stevengj/SoftGlobalScope.jl")
+    (synopsis "Utilities for soft global scope in interactive Julia environments")
+    (description
+"SoftGlobalScope is a package for the Julia language that simplifies
+the variable scoping rules for code in global scope.  It is intended for
+interactive shells to make it easier to work interactively with Julia,
+especially for beginners.")
+    (license license:expat)))
+
 (define-public julia-zygote
   (package
     (name "julia-zygote")