diff mbox series

[bug#52198] gnu: ghc: Fix build on i686-linux.

Message ID 20211130111427.3199918-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#52198] gnu: ghc: Fix build on i686-linux. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier Nov. 30, 2021, 11:14 a.m. UTC
* gnu/packages/haskell.scm (ghc-8.10)[arguments]<#:phases>: Fix failing test.
---
 gnu/packages/haskell.scm | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)


base-commit: f22dfba53032c59fb260173143abf0e4e9a4f1e1

Comments

Lars-Dominik Braun Nov. 30, 2021, 3:57 p.m. UTC | #1
Hi zimoun,

I locally built ghc@8.10 and this test indeed fails without/succeeds
with the patch. There’s also an issue over at the GHC tracker
about this failure, so I’m assuming it’s safe to skip:
https://gitlab.haskell.org/ghc/ghc/-/issues/17300

I pushed this patch to core-updates-frozen as
afc4945d44aeb6750b980abddbfda66f6ccb6b18. Thank you!

Cheers,
Lars
Simon Tournier Nov. 30, 2021, 4:02 p.m. UTC | #2
Hi Lars,

On Tue, 30 Nov 2021 at 16:57, Lars-Dominik Braun <lars@6xq.net> wrote:

> I locally built ghc@8.10 and this test indeed fails without/succeeds
> with the patch. There’s also an issue over at the GHC tracker
> about this failure, so I’m assuming it’s safe to skip:
> https://gitlab.haskell.org/ghc/ghc/-/issues/17300

I have compiled some ghc-* packages for i686 in order to check and
until now, everything is ok.  Let the CI rebuild everything and then
fix case per case; hoping this failing test about 'quasiquotation'
would not lead to reveal breakage of leaves.


> I pushed this patch to core-updates-frozen as
> afc4945d44aeb6750b980abddbfda66f6ccb6b18. Thank you!

Thanks.

Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 69a806e635..d3db023f08 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -711,12 +712,18 @@  (define-public ghc-8.10
                  (("\\]\\), " all)
                   (string-append all "expect_broken(0)], ")))))
            ;; TODO: Turn this into an undconditional patch on the next rebuild.
-           ,@(if (string=? "i686-linux" (%current-system))
+           ,@(if (string-prefix? "i686" (or (%current-target-system)
+                                                  (%current-system)))
               '((add-after 'skip-more-tests 'skip-failing-tests-i686
                  (lambda _
                    (substitute* '("testsuite/tests/codeGen/should_compile/all.T")
                      (("(test\\('T15155l', )when\\(unregisterised\\(\\), skip\\)" all before)
-                      (string-append before "when(arch('i386'), skip)"))))))
+                      (string-append before "when(arch('i386'), skip)")))
+                   ;; Unexpected failures:
+                   ;;    quasiquotation/T14028.run  T14028 [bad stderr] (dyn)
+                   (substitute* '("testsuite/tests/quasiquotation/all.T")
+                     (("unless\\(config.have_ext_interp, skip\\),")
+                      "unless(config.have_ext_interp, skip), when(arch('i386'), skip),")))))
               '())))))
     (native-search-paths (list (search-path-specification
                                 (variable "GHC_PACKAGE_PATH")