diff mbox series

[bug#52171,core-updates-frozen,v2,2/2] gnu: darktable: Build with OpenEXR 3.

Message ID 20211129000421.324049-2-monego@posteo.net
State Accepted
Headers show
Series [bug#52171,core-updates-frozen,v2,1/2] gnu: darktable: Build with libsoup 2. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Nov. 29, 2021, 12:04 a.m. UTC
* gnu/packages/photo.scm (darktable)[arguments]<#:phases>: Rename
'set-LDFLAGS-and-CPATH to 'set-LDFLAGS. Don't set CPATH.
[inputs]: Remove ilmbase. Add imath. Replace openxr-2 with openexr.
---
Removed now unused 'inputs' from the lambda. It would be good if someone could test the OpenEXR export because the button doesn't fit in my screen for me to try.

 gnu/packages/photo.scm | 16 +++++-----------
 1 file changed, 5 insertions(+), 11 deletions(-)

Comments

Leo Famulari Nov. 29, 2021, 2:54 a.m. UTC | #1
On Mon, Nov 29, 2021 at 12:04:21AM +0000, Vinicius Monego wrote:
> * gnu/packages/photo.scm (darktable)[arguments]<#:phases>: Rename
> 'set-LDFLAGS-and-CPATH to 'set-LDFLAGS. Don't set CPATH.
> [inputs]: Remove ilmbase. Add imath. Replace openxr-2 with openexr.

Thanks! Pushed as 3d54f2415672aed64661bed84a043a7f0cee13dd

> Removed now unused 'inputs' from the lambda. It would be good if someone could test the OpenEXR export because the button doesn't fit in my screen for me to try.

It does successfully export EXR files
diff mbox series

Patch

diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 8a07f32f3c..34d9cc3dd0 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -504,18 +504,12 @@  photographic equipment.")
              (substitute* "CMakeLists.txt"
                (("\\$\\{LLVM_INSTALL_PREFIX\\}")
                 (assoc-ref %build-inputs "clang")))))
-         (add-before 'configure 'set-LDFLAGS-and-CPATH
-           (lambda* (#:key inputs outputs #:allow-other-keys)
+         (add-before 'configure 'set-LDFLAGS
+           (lambda* (#:key outputs #:allow-other-keys)
              (setenv "LDFLAGS"
                      (string-append
                       "-Wl,-rpath="
-                      (assoc-ref outputs "out") "/lib/darktable"))
-
-             ;; Ensure the OpenEXR headers are found.
-             (setenv "CPATH"
-                     (string-append
-                      (search-input-directory inputs "include/OpenEXR")
-                      ":" (or (getenv "CPATH") "")))))
+                      (assoc-ref outputs "out") "/lib/darktable"))))
          (add-after 'install 'wrap-program
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (wrap-program (string-append (assoc-ref outputs "out")
@@ -550,7 +544,7 @@  photographic equipment.")
        ("graphicsmagick" ,graphicsmagick)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("gtk+" ,gtk+)
-       ("ilmbase" ,ilmbase)
+       ("imath" ,imath)
        ("iso-codes" ,iso-codes) ;optional, for language names in the preferences
        ("json-glib" ,json-glib)
        ("lcms" ,lcms)
@@ -569,7 +563,7 @@  photographic equipment.")
        ("libxslt" ,libxslt)
        ("lua" ,lua) ;optional, for plugins
        ("opencl-icd-loader" ,opencl-icd-loader) ;optional, for OpenCL support
-       ("openexr" ,openexr-2) ;optional, for EXR import/export
+       ("openexr" ,openexr) ;optional, for EXR import/export
        ("openjpeg" ,openjpeg) ;optional, for JPEG2000 export
        ("osm-gps-map" ,osm-gps-map) ;optional, for geotagging view
        ("pugixml" ,pugixml)