diff mbox series

[bug#52162] gnu: subversion: Add --enable-plaintext-password-storage flag

Message ID 20211128154110.25964-1-philipk@posteo.net
State New
Headers show
Series [bug#52162] gnu: subversion: Add --enable-plaintext-password-storage flag | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Philip Kaludercic Nov. 28, 2021, 3:41 p.m. UTC
* version-control.scm (subversion): Enable plain text passwords while
compiling SVN, undoing the controversial move to disable them by the
maintainers. See also
https://lists.apache.org/thread/b6g2hx2m3s117wcmno08opl874ons3q8.
---
 gnu/packages/version-control.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Leo Famulari Nov. 28, 2021, 10:08 p.m. UTC | #1
On Sun, Nov 28, 2021 at 03:41:10PM +0000, Philip Kaludercic wrote:
> * version-control.scm (subversion): Enable plain text passwords while
> compiling SVN, undoing the controversial move to disable them by the
> maintainers. See also
> https://lists.apache.org/thread/b6g2hx2m3s117wcmno08opl874ons3q8.

Thanks for the patch!

> -       #:configure-flags '("--enable-static=no")
> +       #:configure-flags '("--enable-static=no"
> +                           "--enable-plaintext-password-storage")

In general, in Guix, we aim to distribute software as it was released by
upstream. We do make changes to fix bugs, but it's outside our normal
activity for us to change defaults from upstream.

This is partly a pragmatic choice (less work to maintain) and partly a
way in which we choose to be "good citizens" with respect to our role as
distributors. But also, because Guix makes it easier for users to
customize their packages compared to other systems like APT and RPM.

I would like to hear other peoples' opinions before we decide about this
patch.
Ricardo Wurmus Nov. 29, 2021, 8:15 a.m. UTC | #2
I’ve read the discussion that ends with an email[1] by Nathan 
Hartman expressing support for enabling the feature but disabling 
it by default in configuration.  Hence I think it would be 
reasonable to wait for a new release addressing it.  In the 
meantime users can define their own package variant with this 
configure flag added.

It doesn’t need to be changed in Guix itself, because this only 
affects users of the package, not other packages that have 
subversion as an input.  So it’s enough to add a new leaf package. 
As a compromise I think it would be acceptable to add a separate 
subversion-plaintext (or whatever) package variant, which will be 
superseded by the official subversion package as soon as a new 
release is made.

[1] 
https://mail-archives.apache.org/mod_mbox/subversion-dev/202110.mbox/%3cCAJT2EHr7wBfMdg0df7hEnv9+JedcjRkFCzP+q21=dvcWrPv84Q@mail.gmail.com%3e
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 10487c6939..ff3dc61456 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1969,7 +1969,8 @@  (define-public subversion
     (arguments
      '(#:parallel-tests? #f             ; TODO Seems to cause test failures on
                                         ; i686-linux
-       #:configure-flags '("--enable-static=no")
+       #:configure-flags '("--enable-static=no"
+                           "--enable-plaintext-password-storage")
        #:phases
        (modify-phases %standard-phases
          (add-after 'configure 'patch-libtool-wrapper-ls