diff mbox series

[bug#52160,7/7] gnu: python-language-server: Add deprecated alias.

Message ID 20211128150855.31108-7-jgart@dismail.de
State Accepted
Headers show
Series [bug#52160,1/7] gnu: python-parso: Update to 0.8.2. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

jgart Nov. 28, 2021, 3:08 p.m. UTC
* gnu/packages/python-xyz.scm (python-language-server): New variable.

Add deprecated alias for package removed in the parent commit.
---
 gnu/packages/python-xyz.scm | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4a0b811ed6..b7fff3cd89 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5028,6 +5028,9 @@  (define-public python-lsp-server
 and integrated feature-set for programming Python effectively.")
     (license license:expat)))
 
+(define-public python-language-server
+  (deprecated-package "python-language-server" python-lsp-server))
+
 (define-public python-pathspec
   (package
     (name "python-pathspec")