diff mbox series

[bug#52155] gnu: esbuild: Update to 0.14.0.

Message ID 20211128054358.18213-1-rprior@protonmail.com
State Accepted
Headers show
Series [bug#52155] gnu: esbuild: Update to 0.14.0. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Ryan Prior Nov. 28, 2021, 5:44 a.m. UTC
* gnu/packages/web.scm (esbuild): Update to 0.14.0.
---
 gnu/packages/web.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

--
2.33.1

Comments

Jelle Licht Nov. 28, 2021, 1:14 p.m. UTC | #1
Ryan Prior via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/web.scm (esbuild): Update to 0.14.0.
> ---
>  gnu/packages/web.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> index 0c5e191018..829ca0ac47 100644
> --- a/gnu/packages/web.scm
> +++ b/gnu/packages/web.scm
> @@ -1654,7 +1654,7 @@ (module "tidy")
>  (define-public esbuild
>    (package
>      (name "esbuild")
> -    (version "0.12.28")

Current master has esbuild 0.12.9, is this patch perhaps based on one of
your local branches?

> +    (version "0.14.0")
>      (source
>       (origin
>         (method git-fetch)
> @@ -1663,7 +1663,7 @@ (define-public esbuild
>               (commit (string-append "v" version))))
>         (file-name (git-file-name name version))
>         (sha256
> -        (base32 "1rjsbqshkx930cw07v63g4blzbd9zcm6jbb5yv9k86i59gprh8s8"))
> +        (base32 "09r1xy0kk6c9cpz6q0mxr4why373pwxbm439z2ihq3k1d5kk7x4w"))
>         (modules '((guix build utils)))
>         (snippet
>          '(begin
> --
> 2.33.1

LGTM otherwise, but didn't you recently post an (now outdated) update to
esbuild that also updated one of its dependencies[0]? Does that comment
no longer hold, or is this patch building on top of the other one?

- Jelle

[0]: https://issues.guix.gnu.org/50612
Ryan Prior Nov. 28, 2021, 3:57 p.m. UTC | #2
Oops! I already sent those and they were never commented upon, I should have added this patch to that previous thread instead of starting a new one. I'll do that now and close this one.

The old issue for reference: https://issues.guix.gnu.org/50612

Thanks!
Ryan

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On Sunday, November 28th, 2021 at 1:14 PM, Jelle Licht <jlicht@fsfe.org> wrote:

> Ryan Prior via Guix-patches via guix-patches@gnu.org writes:
>
> > -   gnu/packages/web.scm (esbuild): Update to 0.14.0.
> >
> > gnu/packages/web.scm | 4 ++--
> >
> > 1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> >
> > index 0c5e191018..829ca0ac47 100644
> >
> > --- a/gnu/packages/web.scm
> >
> > +++ b/gnu/packages/web.scm
> >
> > @@ -1654,7 +1654,7 @@ (module "tidy")
> >
> > (define-public esbuild
> >
> > (package
> >
> > (name "esbuild")
> >
> > -   (version "0.12.28")
>
> Current master has esbuild 0.12.9, is this patch perhaps based on one of
>
> your local branches?
>
> > -   (version "0.14.0")
> >
> >     (source
> >
> >     (origin
> >
> >     (method git-fetch)
> >
> >     @@ -1663,7 +1663,7 @@ (define-public esbuild
> >
> >     (commit (string-append "v" version))))
> >
> >     (file-name (git-file-name name version))
> >
> >     (sha256
> >
> > -          (base32 "1rjsbqshkx930cw07v63g4blzbd9zcm6jbb5yv9k86i59gprh8s8"))
> >
> >
> >
> > -          (base32 "09r1xy0kk6c9cpz6q0mxr4why373pwxbm439z2ihq3k1d5kk7x4w"))
> >           (modules '((guix build utils)))
> >           (snippet
> >            '(begin
> >
> >
> >
> > --
> >
> > 2.33.1
>
> LGTM otherwise, but didn't you recently post an (now outdated) update to
>
> esbuild that also updated one of its dependencies[0]? Does that comment
>
> no longer hold, or is this patch building on top of the other one?
>
> -   Jelle
>
>     [0]: https://issues.guix.gnu.org/50612
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0c5e191018..829ca0ac47 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1654,7 +1654,7 @@  (module "tidy")
 (define-public esbuild
   (package
     (name "esbuild")
-    (version "0.12.28")
+    (version "0.14.0")
     (source
      (origin
        (method git-fetch)
@@ -1663,7 +1663,7 @@  (define-public esbuild
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1rjsbqshkx930cw07v63g4blzbd9zcm6jbb5yv9k86i59gprh8s8"))
+        (base32 "09r1xy0kk6c9cpz6q0mxr4why373pwxbm439z2ihq3k1d5kk7x4w"))
        (modules '((guix build utils)))
        (snippet
         '(begin