diff mbox series

[bug#52108,core-updates-frozen] gnu: python-cython: Update to 0.29.24.

Message ID 20211125145631.43219-1-monego@posteo.net
State Accepted
Headers show
Series [bug#52108,core-updates-frozen] gnu: python-cython: Update to 0.29.24. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Nov. 25, 2021, 2:56 p.m. UTC
* gnu/packages/python-xyz.scm (python-cython, python2-cython): Update to
0.29.24.
[arguments]<#:phases>: Don't return #t.
---
I haven't finished running the test suite nor tested the python2 variant.

 gnu/packages/python-xyz.scm | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)


base-commit: 193d7b5b450d2004c26720e488a9cce930542e9e

Comments

Vinicius Monego Nov. 25, 2021, 4:05 p.m. UTC | #1
Oh, this has been pushed already
in	2de88bcd7a67305e23929fd73deca1b5df22aa9e. Closing, sorry about the noise.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e5cdaadb3b..e2db6facb4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5204,13 +5204,13 @@  provides additional functionality on the produced Mallard documents.")
 (define-public python-cython
   (package
     (name "python-cython")
-    (version "0.29.22")
+    (version "0.29.24")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Cython" version))
        (sha256
-        (base32 "01jl3544qwsi8lp6anbl55566xqkjd53x452i7m6gnfilv3q6syz"))))
+        (base32 "0hw4gs18rh4slij1fg252argxhraypld9apbqbl60230qc3lvw6d"))))
     (build-system python-build-system)
     ;; we need the full python package and not just the python-wrapper
     ;; because we need libpython3.3m.so
@@ -5221,7 +5221,7 @@  provides additional functionality on the produced Mallard documents.")
        (modify-phases %standard-phases
          (add-before 'check 'set-HOME
            ;; some tests require access to "$HOME/.cython"
-           (lambda _ (setenv "HOME" "/tmp") #t))
+           (lambda _ (setenv "HOME" "/tmp")))
          (replace 'check
            (lambda _
              ;; Disable compiler optimizations to greatly reduce the running
@@ -5275,8 +5275,7 @@  writing C extensions for Python as easy as Python itself.")
                    ;; prevent it from overriding the Python shared library location.
                    ;; The end result is identical, so we take the easy route.
                    ((" or libname not in os\\.listdir\\(libdir\\)")
-                    ""))
-                 #t)))))))))
+                    "")))))))))))
 
 ;; NOTE: when upgrading numpy please make sure that python-pandas and
 ;; python-scipy still build, as these three packages are often used together.