diff mbox series

[bug#52078,2/2] gnu: julia: Allow parallel tests.

Message ID 20211124142031.64364-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#52078,1/2] gnu: julia: Disable broken tests. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier Nov. 24, 2021, 2:20 p.m. UTC
* gnu/packages/julia.scm (julia)[origin]: Patch.
* gnu/packages/patches/julia-Allow-parallel-build.patch: New file.
---
 gnu/packages/julia.scm                         |  3 ++-
 .../patches/julia-Allow-parallel-build.patch   | 18 ++++++++++++++++++
 2 files changed, 20 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/julia-Allow-parallel-build.patch
diff mbox series

Patch

diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 0d4dd2b7f2..2394cb3d5a 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -145,7 +145,8 @@  (define-public julia
                (base32
                 "1515x8fs25l3f9csbmd1v4nm041zvjnvigy6s5iidy4yrkwdx4r5"))
               (patches
-               (search-patches "julia-SOURCE_DATE_EPOCH-mtime.patch"))))
+               (search-patches "julia-SOURCE_DATE_EPOCH-mtime.patch"
+                               "julia-Allow-parallel-build.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
diff --git a/gnu/packages/patches/julia-Allow-parallel-build.patch b/gnu/packages/patches/julia-Allow-parallel-build.patch
new file mode 100644
index 0000000000..1eb6a4f1f1
--- /dev/null
+++ b/gnu/packages/patches/julia-Allow-parallel-build.patch
@@ -0,0 +1,18 @@ 
+diff --git a/test/runtests.jl b/test/runtests.jl
+index 2f9cd058bb..d8d6d15b8c 100644
+--- a/test/runtests.jl
++++ b/test/runtests.jl
+@@ -83,8 +83,11 @@ prepend!(tests, linalg_tests)
+ import LinearAlgebra
+ cd(@__DIR__) do
+     n = 1
+-    if net_on
+-        n = min(Sys.CPU_THREADS, length(tests))
++    # Allow parallel tests with isolated environment
++    # https://github.com/JuliaLang/julia/issues/43205
++    if net_on || haskey(ENV, "JULIA_CPU_THREADS")
++        x = haskey(ENV, "JULIA_CPU_THREADS") ? parse(Int, ENV["JULIA_CPU_THREADS"]) : Sys.CPU_THREADS
++        n = min(x, length(tests))
+         n > 1 && addprocs_with_testenv(n)
+         LinearAlgebra.BLAS.set_num_threads(1)
+     end