diff mbox series

[bug#51565] PATCH: Update Yggdrasil to new protocol (important breaking changes)

Message ID 20211122221308.685c9f11@riseup.net
State Accepted
Headers show
Series [bug#51565] PATCH: Update Yggdrasil to new protocol (important breaking changes) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Csepp Nov. 22, 2021, 9:13 p.m. UTC
On Mon, 15 Nov 2021 14:10:46 +0000
pukkamustard <pukkamustard@posteo.net> wrote:

> Thanks for this!
> 
> Some minor changes may be needed to make the linter happy:
> 
> raingloom <raingloom@riseup.net> writes:
> 
> [..]
> 
> > [3. text/x-patch; 0002-gnu-Add-go-github-com-rivo-uniseg.patch]...  
> 
> Linter complains that a line is too long:
> 
> gnu/packages/golang.scm:8885:0: go-github-com-rivo-uniseg@0.2.0: line
> 8885 is way too long (93 characters)
> 
> >
> > [4. text/x-patch;
> > 0003-gnu-Add-go-github-com-mattn-go-runewidth.patch]...  
> 
> Linter complains about the synopsis. Maybe: "Go functions for getting
> fixed width of characters or strings"?
> 
> Does seem like a bit of a duplication of the description...
> 
> > [5. text/x-patch;
> > 0004-gnu-go-github-com-cheggaaa-pb-Update-to-3.0.8.patch]...
> >
> > [6. text/x-patch;
> > 0005-gnu-Rename-go-github-com-cheggaaa-pb-to-go-github-co.patch]...
> >
> > [7. text/x-patch;
> > 0006-gnu-Add-go-github-com-arceliar-ironwood.patch]...  
> 
> Lines in descriptions are too long and should be wrapped.
> 
> A synopsis is required. Maybe: "Ironwood is a Go network routing
> library using cryptographic keys as addresses"?

Heck, I think I meant to run the linter but it was getting late and I
just wanted to be done with the patch. Well, here is an updated patch
list.

Comments

Csepp Nov. 28, 2021, 8:47 p.m. UTC | #1
On Mon, 22 Nov 2021 22:13:08 +0100
raingloom <raingloom@riseup.net> wrote:

> On Mon, 15 Nov 2021 14:10:46 +0000
> pukkamustard <pukkamustard@posteo.net> wrote:
> 
> > Thanks for this!
> > 
> > Some minor changes may be needed to make the linter happy:
> > 
> > raingloom <raingloom@riseup.net> writes:
> > 
> > [..]
> > 
> > > [3. text/x-patch;
> > > 0002-gnu-Add-go-github-com-rivo-uniseg.patch]...  
> > 
> > Linter complains that a line is too long:
> > 
> > gnu/packages/golang.scm:8885:0: go-github-com-rivo-uniseg@0.2.0:
> > line 8885 is way too long (93 characters)
> > 
> > >
> > > [4. text/x-patch;
> > > 0003-gnu-Add-go-github-com-mattn-go-runewidth.patch]...  
> > 
> > Linter complains about the synopsis. Maybe: "Go functions for
> > getting fixed width of characters or strings"?
> > 
> > Does seem like a bit of a duplication of the description...
> > 
> > > [5. text/x-patch;
> > > 0004-gnu-go-github-com-cheggaaa-pb-Update-to-3.0.8.patch]...
> > >
> > > [6. text/x-patch;
> > > 0005-gnu-Rename-go-github-com-cheggaaa-pb-to-go-github-co.patch]...
> > >
> > > [7. text/x-patch;
> > > 0006-gnu-Add-go-github-com-arceliar-ironwood.patch]...  
> > 
> > Lines in descriptions are too long and should be wrapped.
> > 
> > A synopsis is required. Maybe: "Ironwood is a Go network routing
> > library using cryptographic keys as addresses"?
> 
> Heck, I think I meant to run the linter but it was getting late and I
> just wanted to be done with the patch. Well, here is an updated patch
> list.

Bump. Could someome merge this if everything is in order?
Ludovic Courtès Dec. 1, 2021, 3:27 p.m. UTC | #2
Hi raingloom,

Apologies for the delay.

raingloom <raingloom@riseup.net> skribis:

>>From 776202eb2d0610e51f5168d108ce80a4096b10d4 Mon Sep 17 00:00:00 2001
> From: raingloom <raingloom@riseup.net>
> Date: Wed, 3 Nov 2021 21:40:37 +0100
> Subject: [PATCH 8/8] gnu: yggdrasil: Update to 0.4.1.
>
> * gnu/packages/networking.scm (yggdrasil): Update to 0.4.1.
> * gnu/packages/patches/yggdrasil-extra-config.patch: Update for new version.

OK.

>>From ce6e34a490816fd9c093fec3b9124bff26620e1f Mon Sep 17 00:00:00 2001
> From: raingloom <raingloom@riseup.net>
> Date: Tue, 2 Nov 2021 06:50:36 +0000
> Subject: [PATCH 6/8] gnu: Add go-github-com-arceliar-ironwood.
>
> * gnu/packages/golang.scm (go-github-com-arceliar-ironwood): New variable.

OK.

>>From 1b4bfd5a947902f453e47a510ab058ff459412f5 Mon Sep 17 00:00:00 2001
> From: raingloom <raingloom@riseup.net>
> Date: Tue, 2 Nov 2021 06:46:57 +0000
> Subject: [PATCH 5/8] gnu: Rename go-github-com-cheggaaa-pb to
>  go-github-com-cheggaaa-pb-v3.
>
> * gnu/packages/golang.scm:
>   (go-github-com-cheggaaa-pb): Rename variable.
>   (go-github-com-cheggaaa-pb-v3): New variable.
> ---
>  gnu/packages/golang.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index 4033806c7f..d0435b5469 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -7945,9 +7945,9 @@ (define-public go-github-com-arceliar-phony
>  inspired by the causal messaging system in the Pony programming language.")
>        (license license:expat))))
>  
> -(define-public go-github-com-cheggaaa-pb
> +(define-public go-github-com-cheggaaa-pb-v3
>    (package
> -    (name "go-github-com-cheggaaa-pb")
> +    (name "go-github-com-cheggaaa-pb-v3")

Why rename?  If we do need to rename, let’s add a ‘deprecated-package’
definition to allow users to notice and get a smooth upgrade.

>>From 6a4220dbb3cbb56cc818bd2f2714484e5f8682e4 Mon Sep 17 00:00:00 2001
> From: raingloom <raingloom@riseup.net>
> Date: Tue, 2 Nov 2021 06:45:47 +0000
> Subject: [PATCH 4/8] gnu: go-github-com-cheggaaa-pb: Update to 3.0.8.
>
> * gnu/packages/golang.scm (go-github-com-cheggaaa-pb): Update to 3.0.8.

Could you mention input changes?

>>From a234dd530900d0914a9972ad5a22a1fe303c1bc5 Mon Sep 17 00:00:00 2001
> From: raingloom <raingloom@riseup.net>
> Date: Tue, 2 Nov 2021 06:37:17 +0000
> Subject: [PATCH 3/8] gnu: Add go-github-com-mattn-go-runewidth.
>
> * gnu/packages/golang.scm (go-github-com-mattn-go-runewidth): New variable.

[...]

> +    (home-page "https://github.com/mattn/go-runewidth")
> +    (synopsis "Rune width implementation for Go")
> +    (description
> +      "Provides functions to get fixed width of the character or string.")

Please write a full sentence:

  https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html

>>From 4732bee7bdbea38292afe9f6b1149986dbfabcb7 Mon Sep 17 00:00:00 2001
> From: raingloom <raingloom@riseup.net>
> Date: Tue, 2 Nov 2021 06:37:11 +0000
> Subject: [PATCH 2/8] gnu: Add go-github-com-rivo-uniseg.
>
> * gnu/packages/golang.scm (go-github-com-rivo-uniseg): New variable.

[...]

> +    (synopsis "Unicode Text Segmentation for Go")
> +    (description
> +      "Package uniseg implements Unicode Text Segmentation according to Unicode
> +Standard Annex #29
> +(@url{http://unicode.org/reports/tr29/,http://unicode.org/reports/tr29/}).
> +")

Ditto.

>>From c11a2cf43ddd6108b57c24ef9669655b677ce276 Mon Sep 17 00:00:00 2001
> From: raingloom <raingloom@riseup.net>
> Date: Tue, 2 Nov 2021 06:36:37 +0000
> Subject: [PATCH 1/8] gnu: Add go-github-com-vividcortex-ewma.
>
> * gnu/packages/golang.scm (go-github-com-vividcortex-ewma): New variable.

[...]

> +    (home-page "https://github.com/VividCortex/ewma")
> +    (synopsis "EWMA")
> +    (description
> +      "Package ewma implements exponentially weighted moving averages.")

Ditto.

Could you send updated patches?

TIA,
Ludo’.
Csepp Dec. 1, 2021, 4:03 p.m. UTC | #3
On Wed, 01 Dec 2021 16:27:23 +0100
Ludovic Courtès <ludo@gnu.org> wrote:

> Hi raingloom,
> 
> Apologies for the delay.
> 
> raingloom <raingloom@riseup.net> skribis:
> 
> >>From 776202eb2d0610e51f5168d108ce80a4096b10d4 Mon Sep 17 00:00:00
> >>2001  
> > From: raingloom <raingloom@riseup.net>
> > Date: Wed, 3 Nov 2021 21:40:37 +0100
> > Subject: [PATCH 8/8] gnu: yggdrasil: Update to 0.4.1.
> >
> > * gnu/packages/networking.scm (yggdrasil): Update to 0.4.1.
> > * gnu/packages/patches/yggdrasil-extra-config.patch: Update for new
> > version.  
> 
> OK.
> 
> >>From ce6e34a490816fd9c093fec3b9124bff26620e1f Mon Sep 17 00:00:00
> >>2001  
> > From: raingloom <raingloom@riseup.net>
> > Date: Tue, 2 Nov 2021 06:50:36 +0000
> > Subject: [PATCH 6/8] gnu: Add go-github-com-arceliar-ironwood.
> >
> > * gnu/packages/golang.scm (go-github-com-arceliar-ironwood): New
> > variable.  
> 
> OK.
> 
> >>From 1b4bfd5a947902f453e47a510ab058ff459412f5 Mon Sep 17 00:00:00
> >>2001  
> > From: raingloom <raingloom@riseup.net>
> > Date: Tue, 2 Nov 2021 06:46:57 +0000
> > Subject: [PATCH 5/8] gnu: Rename go-github-com-cheggaaa-pb to
> >  go-github-com-cheggaaa-pb-v3.
> >
> > * gnu/packages/golang.scm:
> >   (go-github-com-cheggaaa-pb): Rename variable.
> >   (go-github-com-cheggaaa-pb-v3): New variable.
> > ---
> >  gnu/packages/golang.scm | 4 ++--
> >  1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> > index 4033806c7f..d0435b5469 100644
> > --- a/gnu/packages/golang.scm
> > +++ b/gnu/packages/golang.scm
> > @@ -7945,9 +7945,9 @@ (define-public go-github-com-arceliar-phony
> >  inspired by the causal messaging system in the Pony programming
> > language.") (license license:expat))))
> >  
> > -(define-public go-github-com-cheggaaa-pb
> > +(define-public go-github-com-cheggaaa-pb-v3
> >    (package
> > -    (name "go-github-com-cheggaaa-pb")
> > +    (name "go-github-com-cheggaaa-pb-v3")  
> 
> Why rename?  If we do need to rename, let’s add a ‘deprecated-package’
> definition to allow users to notice and get a smooth upgrade.

Without a rename guix import go gets confused and imports it again
under that name. It didn't seem like anything was using it so I went
with a rename, but I guess someone's channel might be depending on it.
(although I doubt it)
What would proper deprecation look like? Just inheriting from the new
package, changing the name field, and marking it as deprecated?

> >>From 6a4220dbb3cbb56cc818bd2f2714484e5f8682e4 Mon Sep 17 00:00:00
> >>2001  
> > From: raingloom <raingloom@riseup.net>
> > Date: Tue, 2 Nov 2021 06:45:47 +0000
> > Subject: [PATCH 4/8] gnu: go-github-com-cheggaaa-pb: Update to
> > 3.0.8.
> >
> > * gnu/packages/golang.scm (go-github-com-cheggaaa-pb): Update to
> > 3.0.8.  
> 
> Could you mention input changes?
> 
> >>From a234dd530900d0914a9972ad5a22a1fe303c1bc5 Mon Sep 17 00:00:00
> >>2001  
> > From: raingloom <raingloom@riseup.net>
> > Date: Tue, 2 Nov 2021 06:37:17 +0000
> > Subject: [PATCH 3/8] gnu: Add go-github-com-mattn-go-runewidth.
> >
> > * gnu/packages/golang.scm (go-github-com-mattn-go-runewidth): New
> > variable.  
> 
> [...]
> 
> > +    (home-page "https://github.com/mattn/go-runewidth")
> > +    (synopsis "Rune width implementation for Go")
> > +    (description
> > +      "Provides functions to get fixed width of the character or
> > string.")  
> 
> Please write a full sentence:
> 
>   https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html
> 
> >>From 4732bee7bdbea38292afe9f6b1149986dbfabcb7 Mon Sep 17 00:00:00
> >>2001  
> > From: raingloom <raingloom@riseup.net>
> > Date: Tue, 2 Nov 2021 06:37:11 +0000
> > Subject: [PATCH 2/8] gnu: Add go-github-com-rivo-uniseg.
> >
> > * gnu/packages/golang.scm (go-github-com-rivo-uniseg): New
> > variable.  
> 
> [...]
> 
> > +    (synopsis "Unicode Text Segmentation for Go")
> > +    (description
> > +      "Package uniseg implements Unicode Text Segmentation
> > according to Unicode +Standard Annex #29
> > +(@url{http://unicode.org/reports/tr29/,http://unicode.org/reports/tr29/}).
> > +")  
> 
> Ditto.
> 
> >>From c11a2cf43ddd6108b57c24ef9669655b677ce276 Mon Sep 17 00:00:00
> >>2001  
> > From: raingloom <raingloom@riseup.net>
> > Date: Tue, 2 Nov 2021 06:36:37 +0000
> > Subject: [PATCH 1/8] gnu: Add go-github-com-vividcortex-ewma.
> >
> > * gnu/packages/golang.scm (go-github-com-vividcortex-ewma): New
> > variable.  
> 
> [...]
> 
> > +    (home-page "https://github.com/VividCortex/ewma")
> > +    (synopsis "EWMA")
> > +    (description
> > +      "Package ewma implements exponentially weighted moving
> > averages.")  
> 
> Ditto.
> 
> Could you send updated patches?
> 
> TIA,
> Ludo’.
Ludovic Courtès Dec. 2, 2021, 9:15 a.m. UTC | #4
Hi,

raingloom <raingloom@riseup.net> skribis:

>> > -(define-public go-github-com-cheggaaa-pb
>> > +(define-public go-github-com-cheggaaa-pb-v3
>> >    (package
>> > -    (name "go-github-com-cheggaaa-pb")
>> > +    (name "go-github-com-cheggaaa-pb-v3")  
>> 
>> Why rename?  If we do need to rename, let’s add a ‘deprecated-package’
>> definition to allow users to notice and get a smooth upgrade.
>
> Without a rename guix import go gets confused and imports it again
> under that name.

Ah that makes sense; would be worth adding a comment above.

> It didn't seem like anything was using it so I went with a rename, but
> I guess someone's channel might be depending on it.  (although I doubt
> it) What would proper deprecation look like? Just inheriting from the
> new package, changing the name field, and marking it as deprecated?

Yes, you can grep for ‘deprecated-package’ in gnu/packages/*.scm.

Thanks,
Ludo’.
diff mbox series

Patch

From c11a2cf43ddd6108b57c24ef9669655b677ce276 Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@riseup.net>
Date: Tue, 2 Nov 2021 06:36:37 +0000
Subject: [PATCH 1/8] gnu: Add go-github-com-vividcortex-ewma.

* gnu/packages/golang.scm (go-github-com-vividcortex-ewma): New variable.
---
 gnu/packages/golang.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cc2a4ebc16..84e7387408 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8839,3 +8839,24 @@  (define-public go-gopkg-in-djherbis-times-v1
     (description
      "Provides a platform-independent way to get atime, mtime, ctime and btime for files.")
     (license license:expat)))
+
+(define-public go-github-com-vividcortex-ewma
+  (package
+    (name "go-github-com-vividcortex-ewma")
+    (version "1.2.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/VividCortex/ewma")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "0whx516l9nm4n41spagb605ry7kfnz1qha96mcshnfjlahhnnylq"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/VividCortex/ewma"))
+    (home-page "https://github.com/VividCortex/ewma")
+    (synopsis "EWMA")
+    (description
+      "Package ewma implements exponentially weighted moving averages.")
+    (license license:expat)))
-- 
2.33.1