diff mbox series

[bug#52039,6/7] gnu: Add ocaml-lambda-term.

Message ID 20211122153526.51833-6-zimon.toutoune@gmail.com
State Accepted
Headers show
Series Add utop. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier Nov. 22, 2021, 3:35 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-lambda-term): New variable.
(omca4.07-lambda-term): Inherit and adjust source.
[arguments]: Set tests.
---
 gnu/packages/ocaml.scm | 51 +++++++++++++++++++++++++++++++-----------
 1 file changed, 38 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 032347a28e..f63a00f1d8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4077,22 +4077,56 @@  (define-public ocaml4.07-zed
        ("ocaml-charinfo-width" ,(package-with-ocaml4.07 ocaml-charinfo-width))
        ("ocaml-react" ,(package-with-ocaml4.07 ocaml-react))))))
 
+(define-public ocaml-lambda-term
+  (package
+    (name "ocaml-lambda-term")
+    (version "3.1.0")
+    (home-page "https://github.com/ocaml-community/lambda-term")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1k0ykiz0vhpyyj9fkss29ajas4fh1xh449j702xkvayqipzj1mkg"))))
+    (build-system dune-build-system)
+    (arguments
+     `(#:test-target "."))
+    (propagated-inputs
+     `(("ocaml-lwt" ,ocaml-lwt)
+       ("ocaml-lwt-log" ,ocaml-lwt-log)
+       ("ocaml-react" ,ocaml-react)
+       ("ocaml-zed" ,ocaml-zed)
+       ("ocaml-camomile" ,ocaml-camomile)
+       ("ocaml-lwt-react" ,ocaml-lwt-react)
+       ("ocaml-mew-vi" ,ocaml-mew-vi)))
+    (synopsis "Terminal manipulation library for OCaml")
+    (description "Lambda-Term is a cross-platform library for manipulating the
+terminal.  It provides an abstraction for keys, mouse events, colors, as well as
+a set of widgets to write curses-like applications.  The main objective of
+Lambda-Term is to provide a higher level functional interface to terminal
+manipulation than, for example, ncurses, by providing a native OCaml interface
+instead of bindings to a C library.")
+    (license license:bsd-3)))
+
 (define-public ocaml4.07-lambda-term
   (package
+    (inherit ocaml-lambda-term)
     (name "ocaml4.07-lambda-term")
     (version "2.0.2")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/diml/lambda-term")
+             (url "https://github.com/ocaml-community/lambda-term")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
         (base32 "0zcjy6fvf0d3i2ssz96asl889n3r6bplyzk7xvb2s3dkxbgcisyy"))))
-    (build-system dune-build-system)
     (arguments
-     `(#:tests? #f
+     `(#:test-target "."
        #:ocaml ,ocaml-4.07
        #:findlib ,ocaml4.07-findlib
        #:dune ,ocaml4.07-dune))
@@ -4100,16 +4134,7 @@  (define-public ocaml4.07-lambda-term
      `(("ocaml-lwt" ,(package-with-ocaml4.07 ocaml-lwt))
        ("ocaml-lwt-log" ,(package-with-ocaml4.07 ocaml-lwt-log))
        ("ocaml-lwt-react" ,(package-with-ocaml4.07 ocaml-lwt-react))
-       ("ocaml-zed" ,ocaml4.07-zed)))
-    (home-page "https://github.com/diml/lambda-term")
-    (synopsis "Terminal manipulation library for OCaml")
-    (description "Lambda-Term is a cross-platform library for manipulating the
-terminal.  It provides an abstraction for keys, mouse events, colors, as well as
-a set of widgets to write curses-like applications.  The main objective of
-Lambda-Term is to provide a higher level functional interface to terminal
-manipulation than, for example, ncurses, by providing a native OCaml interface
-instead of bindings to a C library.")
-    (license license:bsd-3)))
+       ("ocaml-zed" ,ocaml4.07-zed)))))
 
 (define-public ocaml4.07-utop
   (package