diff mbox series

[bug#51853,v2,1/2] gnu: sendgmail: Rename package to match command.

Message ID 20211120054353.987243-2-philip@philipmcgrath.com
State Accepted
Headers show
Series gnu: sendgmail: Rename package; don't limit domain. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Philip McGrath Nov. 20, 2021, 5:43 a.m. UTC
Suggested by Ludo’ in <https://issues.guix.gnu.org/50420#3>.

* gnu/packages/golang.scm
(go-github-com-google-gmail-oauth2-tools-go-sendgmail): Move to ...
* gnu/packages/mail.scm (sendgmail): ... this variable.
Change `propagated-inputs` to `inputs`.
---
 gnu/packages/golang.scm | 36 +-----------------------------------
 gnu/packages/mail.scm   | 36 ++++++++++++++++++++++++++++++++++++
 2 files changed, 37 insertions(+), 35 deletions(-)

Comments

Ludovic Courtès Dec. 10, 2021, 2:12 p.m. UTC | #1
Hi,

Philip McGrath <philip@philipmcgrath.com> skribis:

> Suggested by Ludo’ in <https://issues.guix.gnu.org/50420#3>.
>
> * gnu/packages/golang.scm
> (go-github-com-google-gmail-oauth2-tools-go-sendgmail): Move to ...
> * gnu/packages/mail.scm (sendgmail): ... this variable.
> Change `propagated-inputs` to `inputs`.

[...]

> There are three open pull requests adding this functionality:
>
>   - https://github.com/google/gmail-oauth2-tools/pull/17 (October 2019)
>   - https://github.com/google/gmail-oauth2-tools/pull/26 (May 2020)
>   - https://github.com/google/gmail-oauth2-tools/pull/37 (May 2021)
>     (The patch here is identical to #26, so I just closed this one.)
>
> Meanwhile, the most recent commit to the upstream repository was in
> May 2019: that was the commit that first added `sendgmail`.
>
> This commit adjusts Guix's `sendgmail`, following Postel's advice,
> to make the command "liberal in its receiving behavior" (RFC 760):
> it always accepts email addresses with any domain name, as in #26,
> and it accepts (and ignores) the `-gsuite` flag used in #17.
>
> * gnu/packages/patches/sendgmail-remove-domain-restriction.patch:
> New file. This is the patch from #26.
> * gnu/packages/patches/sendgmail-accept-ignored-gsuite-flag.patch:
> New file, based on #17.
> * gnu/local.mk (dist_patch_DATA): Add the new patches.
> * gnu/packages/mail.scm (sendgmail)[source]: Apply the new patches.
> Increment the "revision" argument to `git-version` from 0 to 1.

Applied both, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cc2a4ebc16..aaf6194460 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -31,6 +31,7 @@ 
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
 ;;; Copyright © 2021 Chadwain Holness <chadwainholness@gmail.com>
+;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3036,41 +3037,6 @@  (define-public go-cloud-google-com-go-compute-metadata
 API service accounts for Go.")
     (license license:asl2.0)))
 
-(define-public go-github-com-google-gmail-oauth2-tools-go-sendgmail
-  (let ((commit "e3229155a4037267ce40f1a3a681f53221aa4d8d")
-        (revision "0"))
-    (package
-      (name "go-github-com-google-gmail-oauth2-tools-go-sendgmail")
-      (version (git-version "0.0.0" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/google/gmail-oauth2-tools")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "1cxpkiaajhq1gjsg47r2b5xgck0r63pvkyrkm7af8c8dw7fyn64f"))))
-      (propagated-inputs
-       `(("go-golang-org-x-oauth2" ,go-golang-org-x-oauth2)
-         ("go-cloud-google-com-go-compute-metadata"
-          ,go-cloud-google-com-go-compute-metadata)))
-      (build-system go-build-system)
-      (arguments
-       '(#:unpack-path "github.com/google/gmail-oauth2-tools"
-         #:import-path "github.com/google/gmail-oauth2-tools/go/sendgmail"))
-      (home-page
-       "https://github.com/google/gmail-oauth2-tools/tree/master/go/sendgmail")
-      (synopsis
-       "Sendmail-compatible tool for using Gmail with @code{git send-email}")
-      (description
-       "The @command{sendgmail} command provides a minimal sendmail-compatible
-front-end that connects to Gmail using OAuth2.  It is specifically designed
-for use with @code{git send-email}.  The command needs a Gmail API key to
-function.")
-      (license license:asl2.0))))
-
 (define-public go-github-com-google-cadvisor
   (let ((commit "2ed7198f77395ee9a172878a0a7ab92ab59a2cfd")
         (revision "0"))
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 0e7134eaf3..891a163f0f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -43,6 +43,7 @@ 
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
 ;;; Copyright © 2021 Benoit Joly <benoit@benoitj.ca>
 ;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4642,3 +4643,38 @@  (define-public rss2email
     ;; GPL version 2 or 3.  NOT 2+.
     (license (list license:gpl2
                    license:gpl3))))
+
+(define-public sendgmail
+  (let ((commit "e3229155a4037267ce40f1a3a681f53221aa4d8d")
+        (revision "0"))
+    (package
+      (name "sendgmail")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/google/gmail-oauth2-tools")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1cxpkiaajhq1gjsg47r2b5xgck0r63pvkyrkm7af8c8dw7fyn64f"))))
+      (inputs
+       `(("go-golang-org-x-oauth2" ,go-golang-org-x-oauth2)
+         ("go-cloud-google-com-go-compute-metadata"
+          ,go-cloud-google-com-go-compute-metadata)))
+      (build-system go-build-system)
+      (arguments
+       '(#:unpack-path "github.com/google/gmail-oauth2-tools"
+         #:import-path "github.com/google/gmail-oauth2-tools/go/sendgmail"))
+      (home-page
+       "https://github.com/google/gmail-oauth2-tools/tree/master/go/sendgmail")
+      (synopsis
+       "Sendmail-compatible tool for using Gmail with @code{git send-email}")
+      (description
+       "The @command{sendgmail} command provides a minimal sendmail-compatible
+front-end that connects to Gmail using OAuth2.  It is specifically designed
+for use with @code{git send-email}.  The command needs a Gmail API key to
+function.")
+      (license license:asl2.0))))