diff mbox series

[bug#51973] gnu: mycli: Update to 1.24.1.

Message ID 20211119111929.7691-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#51973] gnu: mycli: Update to 1.24.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Nov. 19, 2021, 11:19 a.m. UTC
* gnu/packages/databases.scm (mycli): Update to 1.24.1.
[propagated-inputs]: Add missing dependencies.
---
 gnu/packages/databases.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

Comments

Arun Isaac Nov. 19, 2021, 4:08 p.m. UTC | #1
Hi jgart,

Thanks for the patch! I pushed it to master after adding a copyright
header and fixing your commit message as follows.

> [propagated-inputs]: Add missing dependencies.

^ In this line, I explicitly listed the new dependencies.

Regards,
Arun
jgart Nov. 19, 2021, 5:44 p.m. UTC | #2
On Fri, 19 Nov 2021 21:38:33 +0530 Arun Isaac <arunisaac@systemreboot.net> wrote:
> 
> Hi jgart,
> 
> Thanks for the patch! I pushed it to master after adding a copyright
> header and fixing your commit message as follows.
> 
> > [propagated-inputs]: Add missing dependencies.
> 
> ^ In this line, I explicitly listed the new dependencies.

Hi Arun,

I'll make sure to list all inputs changed going forward and adding the copyright statement.

Do you happen to know when it is not required to add a copyright statement?

I think for under ~5-8 lines of code it is not required but I might be wrong on that.

Thank you for reviewing and merging the patch! Much appreciated.

all best,

jgart
Arun Isaac Nov. 22, 2021, 9:48 a.m. UTC | #3
Hi jgart,

> Do you happen to know when it is not required to add a copyright
> statement?

I add a copyright header all the time, even if only a single character
has been changed! It just seemed like the safest thing to do. I don't
know what the legal requirements are.

> I think for under ~5-8 lines of code it is not required but I might be
> wrong on that.

You can fit a lot into 5-8 lines of code. So, perhaps that is too high
for a minimum limit.

Regards,
Arun
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index de161e1864..c1582c709a 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -145,6 +145,7 @@  (define-module (gnu packages databases)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages valgrind)
   #:use-module (gnu packages web)
+  #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xml)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
@@ -618,13 +619,13 @@  (define-public python2-pylibmc
 (define-public mycli
   (package
     (name "mycli")
-    (version "1.22.2")
+    (version "1.24.1")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "mycli" version))
         (sha256
-          (base32 "1lq2x95553vdmhw13cxcgsd2g2i32izhsb7hxd4m1iwf9b3msbpv"))))
+          (base32 "0rij9nw20zhqr7cqnkm8daw8b1wdc9zb6ny1ji9qz5557nz9i3bl"))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f))                    ; tests expect a running MySQL
@@ -634,8 +635,10 @@  (define-public mycli
         ("python-configobj" ,python-configobj)
         ("python-cryptography" ,python-cryptography)
         ("python-prompt-toolkit" ,python-prompt-toolkit)
+        ("python-pyaes" ,python-pyaes)
         ("python-pygments" ,python-pygments)
         ("python-pymysql" ,python-pymysql)
+        ("python-pyperclip" ,python-pyperclip)
         ("python-sqlparse" ,python-sqlparse)))
     (home-page "http://mycli.net")
     (synopsis