diff mbox series

[bug#47852,1/2,v6] gnu: Add sc-im.

Message ID 20211119012218.21932-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#47852,1/2,v6] gnu: Add sc-im. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Nov. 19, 2021, 1:22 a.m. UTC
* gnu/packages/spreadsheet-apps.scm: New file.
    * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
 gnu/local.mk                      |  1 +
 gnu/packages/spreadsheet-apps.scm | 81 +++++++++++++++++++++++++++++++
 2 files changed, 82 insertions(+)
 create mode 100644 gnu/packages/spreadsheet-apps.scm

Comments

Leo Famulari Nov. 22, 2021, 9:20 p.m. UTC | #1
On Thu, Nov 18, 2021 at 08:22:18PM -0500, jgart via Guix-patches via wrote:
>     * gnu/packages/spreadsheet-apps.scm: New file.
>     * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.

Thanks!

I pushed as 10fad03fcf6fdd2edbdab5f939e3c0edb11a88e2 with the following
changes:

* I named the module (gnu packages spreadsheet)
* I removed some unused or duplicated module imports
* I removed the visidata module from GNU_SYSTEM_MODULES
* And I specified the licenses without a prefix, since they are not
needed in this module yet. We only need to prefix licenses when there is
a namespace collision between licenses and same-named packages, for
example with 'expat'.
jgart Nov. 22, 2021, 11:23 p.m. UTC | #2
On Mon, 22 Nov 2021 16:20:27 -0500 Leo Famulari <leo@famulari.name> wrote:
> On Thu, Nov 18, 2021 at 08:22:18PM -0500, jgart via Guix-patches via wrote:
> >     * gnu/packages/spreadsheet-apps.scm: New file.
> >     * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
> 
> Thanks!
> 
> I pushed as 10fad03fcf6fdd2edbdab5f939e3c0edb11a88e2 with the following
> changes:
> 
> * I named the module (gnu packages spreadsheet)
> * I removed some unused or duplicated module imports
> * I removed the visidata module from GNU_SYSTEM_MODULES

Oops I had forgotten to do that.

> * And I specified the licenses without a prefix, since they are not
> needed in this module yet. We only need to prefix licenses when there is
> a namespace collision between licenses and same-named packages, for
> example with 'expat'.

That's good to know. I always wondered what was the reason for prefixing licenses... Now I know :)

Thank you! Much appreciated.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 7cc06c8212..06e97878a6 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -519,6 +519,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/sawfish.scm			\
   %D%/packages/scanner.scm			\
   %D%/packages/scheme.scm			\
+  %D%/packages/spreadsheets-apps.scm			\
   %D%/packages/screen.scm			\
   %D%/packages/scribus.scm			\
   %D%/packages/scsi.scm				\
diff --git a/gnu/packages/spreadsheet-apps.scm b/gnu/packages/spreadsheet-apps.scm
new file mode 100644
index 0000000000..a2d82a111e
--- /dev/null
+++ b/gnu/packages/spreadsheet-apps.scm
@@ -0,0 +1,81 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
+;;; Copyright © 2021 Jorge Gomez <jgart@dismail.de>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages spreadsheet-apps)
+  #:use-module (guix packages)
+  #:use-module (guix git-download)
+  #:use-module (guix download)
+  #:use-module (guix utils)
+  #:use-module (guix build-system gnu)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages base)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages maths)
+  #:use-module (gnu packages statistics)
+  #:use-module (gnu packages xml)
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages bison)
+  #:use-module (gnu packages ncurses))
+
+(define-public sc-im
+    (package
+      (name "sc-im")
+      (version "0.8.2")
+      (home-page "https://github.com/andmarti1424/sc-im")
+      (source (origin
+                (method git-fetch)
+                (uri
+                  (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
+                (file-name (git-file-name name version))
+                (sha256
+                  (base32
+                    "1nrjnw8sg75i0hkcbvjv7gydjddxjm27d5m1qczpg29fk9991q8z"))))
+      (build-system gnu-build-system)
+      (arguments
+        ;; There are no tests at the moment.
+        ;; https://github.com/andmarti1424/sc-im/issues/537
+        ;; https://github.com/andmarti1424/sc-im/pull/385
+        `(#:tests? #f
+          #:make-flags (list "-C" "src"
+                          (string-append "CC=" ,(cc-for-target))
+                          (string-append "prefix=" %output))
+          #:phases
+            (modify-phases
+               %standard-phases
+                 (delete 'configure))))
+      (inputs
+        `(("gnuplot" ,gnuplot)
+          ("libxls" ,libxls)
+          ("libxlsxwriter" ,libxlsxwriter)
+          ("libxml2" ,libxml2)
+          ("libzip" ,libzip)
+          ("ncurses" ,ncurses)))
+      (native-inputs
+        `(("pkg-config" ,pkg-config)
+          ("which" ,which)
+          ("bison" ,bison)))
+      (synopsis "Spreadsheet program with vim-like keybindings")
+      (description
+ "@code{sc-im} is a highly configurable spreadsheet program
+ providing a vim-like experience.  @code{sc-im} supports @{gnuplot} interaction,
+ functions for sorting and filtering, 256 color support, and much more.")
+      (license license:bsd-4)))