diff mbox series

[bug#51936,core-updates-frozen] gnu: gnome-screenshot: Fix build with Meson 0.60.0.

Message ID 20211118062610.11141-1-jackhill@jackhill.us
State Accepted
Headers show
Series [bug#51936,core-updates-frozen] gnu: gnome-screenshot: Fix build with Meson 0.60.0. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Jack Hill Nov. 18, 2021, 6:26 a.m. UTC
* gnu/packages/patches/gnome-screenshot-meson-0.60.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/gnome.scm (gnome-screenshot)[patches]: New field.
---

This change patches gnome-screenshot so that it can build with Meson
0.60.0, which is the default Meson on core-updates-frozen. The patch is
from a change that I submitted upstream [0] and based on the advice in a
corresponding Meson issue [1].

As an alternative to this change, we could instead build
gnome-screenshot with Meson 0.59.

[0] https://gitlab.gnome.org/GNOME/gnome-screenshot/-/merge_requests/57
[1] https://github.com/mesonbuild/meson/issues/9441

 gnu/local.mk                                  |  1 +
 gnu/packages/gnome.scm                        |  4 +-
 .../patches/gnome-screenshot-meson-0.60.patch | 39 +++++++++++++++++++
 3 files changed, 43 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/gnome-screenshot-meson-0.60.patch

Comments

Ludovic Courtès Nov. 18, 2021, 8:54 a.m. UTC | #1
Hey Jack,

Jack Hill <jackhill@jackhill.us> skribis:

> * gnu/packages/patches/gnome-screenshot-meson-0.60.patch: New file.
> * gnu/local.mk (dist_patch_DATA): Add it.
> * gnu/packages/gnome.scm (gnome-screenshot)[patches]: New field.
> ---
>
> This change patches gnome-screenshot so that it can build with Meson
> 0.60.0, which is the default Meson on core-updates-frozen. The patch is
> from a change that I submitted upstream [0] and based on the advice in a
> corresponding Meson issue [1].
>
> As an alternative to this change, we could instead build
> gnome-screenshot with Meson 0.59.
>
> [0] https://gitlab.gnome.org/GNOME/gnome-screenshot/-/merge_requests/57
> [1] https://github.com/mesonbuild/meson/issues/9441

Wonderful!  Applied.

Thanks for inaugurating this core-updates-frozen sprint!  :-)

Ludo’.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index e710766eda..dde9c99a1f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1164,6 +1164,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/gmp-faulty-test.patch			\
   %D%/packages/patches/gnash-fix-giflib-version.patch	        \
   %D%/packages/patches/gnome-online-miners-tracker-3.patch	\
+  %D%/packages/patches/gnome-screenshot-meson-0.60.patch	\
   %D%/packages/patches/gnome-shell-disable-test.patch		\
   %D%/packages/patches/gnome-settings-daemon-gc.patch		\
   %D%/packages/patches/gnome-tweaks-search-paths.patch		\
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8677a6849d..f07ff28701 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9212,7 +9212,9 @@  (define-public gnome-screenshot
                            name "-" version ".tar.xz"))
        (sha256
         (base32
-         "1qm544ymwibk31s30k47vnn79xg30m18r7l4di0c57g375dak31n"))))
+         "1qm544ymwibk31s30k47vnn79xg30m18r7l4di0c57g375dak31n"))
+       (patches
+        (search-patches "gnome-screenshot-meson-0.60.patch"))))
     (build-system meson-build-system)
     (arguments
      '(#:phases
diff --git a/gnu/packages/patches/gnome-screenshot-meson-0.60.patch b/gnu/packages/patches/gnome-screenshot-meson-0.60.patch
new file mode 100644
index 0000000000..c80ce9d6a3
--- /dev/null
+++ b/gnu/packages/patches/gnome-screenshot-meson-0.60.patch
@@ -0,0 +1,39 @@ 
+Fixes build issue with Meson 0.60.0. Taken from upstream
+https://gitlab.gnome.org/GNOME/gnome-screenshot/-/merge_requests/57
+
+From b60dad3c2536c17bd201f74ad8e40eb74385ed9f Mon Sep 17 00:00:00 2001
+From: Jack Hill <jackhill@jackhill.us>
+Date: Thu, 18 Nov 2021 00:46:58 -0500
+Subject: [PATCH] meson: remove extraneous positional argument
+
+* data/meson.build (desktop_file)
+  (metainfo_file): Remove extraneous positional argument.
+
+Closes #186
+---
+ data/meson.build | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index fd570b3..4e2e2e8 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -1,7 +1,6 @@
+ gnome = import('gnome')
+ 
+ desktop_file = i18n.merge_file(
+-  'desktop',
+   type: 'desktop',
+   input: 'org.gnome.Screenshot.desktop.in',
+   output: 'org.gnome.Screenshot.desktop',
+@@ -23,7 +22,6 @@ if desktop_file_validate.found()
+ endif
+ 
+ metainfo_file = i18n.merge_file(
+-  'appdata',
+   input: 'org.gnome.Screenshot.metainfo.xml.in',
+   output: 'org.gnome.Screenshot.metainfo.xml',
+   po_dir: join_paths(meson.current_source_dir(), '../po'),
+-- 
+2.33.1
+