diff mbox series

[bug#51933] gnu: Add python-logzero.

Message ID 20211118013051.23683-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#51933] gnu: Add python-logzero. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Nov. 18, 2021, 1:30 a.m. UTC
* gnu/packages/python-xyz.scm (python-logzero): New variable.
---
 gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Mathieu Othacehe Dec. 26, 2021, 6:18 p.m. UTC | #1
> * gnu/packages/python-xyz.scm (python-logzero): New variable.

Pushed, thanks!

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 696028f2df..e8728ad96e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -272,6 +272,35 @@  (define-public python-janus
 design}.")
     (license license:asl2.0)))
 
+(define-public python-logzero
+  (package
+  (name "python-logzero")
+  (version "1.7.0")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (pypi-uri "logzero" version))
+      (sha256
+        (base32 "10nh186vk6hpnpfycym44gja4fja0jyzw7q8dwimfd1rmv9xswvz"))))
+  (build-system python-build-system)
+  (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-runner" ,python-pytest-runner)))
+  (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "pytest")))))))
+  (home-page "https://github.com/metachris/logzero")
+  (synopsis "Robust and effective logging for Python")
+  (description
+"@code{logzero} provides a fully configured Python logger object for
+easy logging and rotating to a console or a file.")
+  (license license:expat)))
+
 (define-public python-logbook
   (package
     (name "python-logbook")