diff mbox series

[bug#51896,v2,5/5] gnu: coq-stdpp: Adjust '#:make-flags'.

Message ID 20211116185154.22062-5-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#51896,v2,1/5] gnu: Add coq-semantics. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier Nov. 16, 2021, 6:51 p.m. UTC
* gnu/packages/coq.scm (coq-stdpp)[arguments]<#:make-flags>: Set install
destination.
<#:phases>: Remove replace 'install.
---
 gnu/packages/coq.scm | 11 ++++-------
 1 file changed, 4 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index aeba0eb5da..a0579f8869 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -633,15 +633,12 @@  (define-public coq-stdpp
      `(("coq" ,coq)))
     (arguments
      `(#:tests? #f ; Tests are executed during build phase.
+       #:make-flags (list (string-append "COQLIBINSTALL="
+                                         (assoc-ref %outputs "out")
+                                         "/lib/coq/user-contrib"))
        #:phases
        (modify-phases %standard-phases
-         (delete 'configure)
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (invoke "make"
-                     (string-append "COQLIB=" (assoc-ref outputs "out")
-                                    "/lib/coq/")
-                     "install"))))))
+         (delete 'configure))))
     (description "This project contains an extended \"Standard Library\" for
 Coq called coq-std++.  The key features are:
 @itemize