diff mbox series

[bug#51896,v2,3/5] gnu: coq-autosubst: Adjust '#:make-flags'.

Message ID 20211116185154.22062-3-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#51896,v2,1/5] gnu: Add coq-semantics. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier Nov. 16, 2021, 6:51 p.m. UTC
* gnu/packages/coq.scm (coq-autosubst)[arguments]<#:make-flags>: Set install
destination.
<#:phases>: Remove replace 'install.
---
 gnu/packages/coq.scm | 12 ++++--------
 1 file changed, 4 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 602a2d305d..fc739a0475 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -502,16 +502,12 @@  (define-public coq-autosubst
       (build-system gnu-build-system)
       (arguments
        `(#:tests? #f
+       #:make-flags (list (string-append "COQLIBINSTALL="
+                                         (assoc-ref %outputs "out")
+                                         "/lib/coq/user-contrib"))
          #:phases
          (modify-phases %standard-phases
-           (delete 'configure)
-           (replace 'install
-             (lambda* (#:key outputs #:allow-other-keys)
-               (setenv "COQLIB" (string-append (assoc-ref outputs "out") "/lib/coq/"))
-               (invoke "make"
-                       (string-append "COQLIB=" (assoc-ref outputs "out")
-                                      "/lib/coq/")
-                       "install"))))))
+           (delete 'configure))))
       (native-inputs
        `(("coq" ,coq)))
       (home-page "https://www.ps.uni-saarland.de/autosubst/")