diff mbox series

[bug#51675,v2,3/5] gnu: Add python-pydoctor.

Message ID 20211114015031.11010-3-singpolyma@singpolyma.net
State New
Headers show
Series [bug#51675,v2,1/5] gnu: python-incremental: Update to 21.3.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Nov. 14, 2021, 1:50 a.m. UTC
* gnu/packages/python-xyz.scm (python-pydoctor): New variable.
---
 gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 68d397d012..1383406885 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27693,3 +27693,38 @@  simple mock/record and a complete capture/replay framework.")
      "Ijson is an iterative JSON parser with standard Python iterator
 interfaces.")
     (license license:bsd-3)))
+
+(define-public python-pydoctor
+  (package
+    (name "python-pydoctor")
+    (version "21.9.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "pydoctor" version))
+        (sha256
+          (base32 "0nknh3k4zv505031ga8ira0d4slvwwm5g5bzjacjidmi2mmjj311"))))
+    (build-system python-build-system)
+    (inputs
+      `(("python-appdirs" ,python-appdirs)
+        ("python-astor" ,python-astor)
+        ("python-attrs" ,python-attrs)
+        ("python-cachecontrol" ,python-cachecontrol)
+        ("python-docutils" ,python-docutils)
+        ("python-importlib-metadata" ,python-importlib-metadata)
+        ("python-importlib-resources" ,python-importlib-resources)
+        ("python-requests" ,python-requests)
+        ("python-twisted" ,python-twisted)))
+    (native-inputs
+      `(("python-beautifulsoup4" ,python-beautifulsoup4)
+        ("python-hypothesis" ,python-hypothesis)
+        ("python-pytest" ,python-pytest)
+        ("python-sphinx" ,python-sphinx)))
+    (home-page "https://github.com/twisted/pydoctor")
+    (synopsis "Python API documentation generator")
+    (description "Pydoctor is a documentation generator that works by static analysis.
+It puts a fair bit of effort into resolving imports and computing inheritance
+hierarchies and, as it aims at documenting Twisted, knows about zope.interface's
+declaration API and can present information about which classes implement which
+interface, and vice versa.")
+    (license license:expat)))