diff mbox series

[bug#51148,v3] gnu: Add python-tinydb.

Message ID 20211112034501.29311-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#51148,v3] gnu: Add python-tinydb. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Nov. 12, 2021, 3:45 a.m. UTC
I forgot to add the copyright at the top.

Attached is version 3 of the patchset.

* gnu/packages/databases.scm (python-tinydb): New variable.
---
 gnu/packages/databases.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Ludovic Courtès Nov. 23, 2021, 8:22 a.m. UTC | #1
Hi,

jgart <jgart@dismail.de> skribis:

> I forgot to add the copyright at the top.

In the meantime another line had been added for you.  :-)

> Attached is version 3 of the patchset.
>
> * gnu/packages/databases.scm (python-tinydb): New variable.

I applied and tweaked indentation.

Thanks, and thanks Vinicius for reviewing,
Ludo’.
jgart Nov. 23, 2021, 8:37 a.m. UTC | #2
On Tue, 23 Nov 2021 09:22:39 +0100 Ludovic Courtès <ludo@gnu.org> wrote:

Thanks Ludo and Vinicius!

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 92a7aa2761..87fa1da895 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -53,6 +53,7 @@ 
 ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
 ;;; Copyright © 2021 Alexandre Hannud Abdo <abdo@member.fsf.org>
 ;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2021 Jorge Gomez <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4072,6 +4073,29 @@  (define-public freetds
 connecting to MS SQL and Sybase servers over TCP/IP.")
     (license license:lgpl2.0+)))
 
+(define-public python-tinydb
+  (package
+    (name "python-tinydb")
+    (version "4.5.2")
+    (source (origin
+      (method url-fetch)
+      (uri (pypi-uri "tinydb" version))
+      (sha256
+       (base32 "1x9c4s42930wwal3ds0plwb57kg5c3gj7kbpy64c29vq478b463x"))))
+    (build-system python-build-system)
+    ;; PyPi tarball does not contain tests and github repository does not
+    ;; have a setup.py file (only pyproject).
+    (arguments `(#:tests? #f))
+    (propagated-inputs
+      `(("python-typing-extensions" ,python-typing-extensions)))
+    (home-page "https://github.com/msiemens/tinydb")
+    (synopsis "TinyDB is a lightweight document oriented database")
+    (description
+"TinyDB is a small document oriented database written in pure Python
+with no external dependencies.  The targets are small apps that would
+be blown away by a SQL-DB or an external database server.")
+    (license license:expat)))
+
 (define-public sequeler
   (package
     (name "sequeler")