diff mbox series

[bug#51779] Add phonesim 1.21

Message ID 20211111221457.6025-1-db@minikn.xyz
State Accepted
Headers show
Series [bug#51779] Add phonesim 1.21 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Demis Balbach Nov. 11, 2021, 10:14 p.m. UTC
---
 gnu/packages/telephony.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Tobias Geerinckx-Rice Nov. 12, 2021, 3:05 p.m. UTC | #1
Demis,

Thanks for the patch!  Here are a few low-hanging thoughts (not a full 
review):

Check the git log for commits adding new packages for the expected 
'change-log-style' commit message.

On 2021-11-11 23:14, Demis Balbach wrote:
> +     `(#:configure-flags
> +       (list "--enable-maintainer-mode"

This is unusual enough to require a comment explaining why it's here.

> +             "CC=gcc")))

This breaks cross-compilation: the cross GCC is called something like 
'x86_64-blah-bloo-gcc', not 'gcc'.  There's a helper in (guix utils) 
IIRC that returns the right cc for the target:

   (string-append "CC=" ,(cc-for-target))

> +    (description "Phone Simulator for modem testing")

This should be at least several lines of complete sentences ("Phonesim 
simulates blah...").

Kind regards,

T G-R

Sent from a Web browser.  Excuse or enjoy my brevity.
Demis Balbach Nov. 23, 2021, 6:37 p.m. UTC | #2
> You can take a look at the complete commit messages in the git log to
> get a feel for what needs to be included in them.

Thank you Josselin.

I'm still quite unfamiliar with patches through mailing lists: Do I have
to change anything in this patch for it to get merged, or should I just
keep the naming convention in mind for future patches?

Greetings,

Demis.
diff mbox series

Patch

diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index a2765ee99f..77914fb4d7 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -20,6 +20,7 @@ 
 ;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright © 2021 Demis Balbach <db@minikn.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -94,6 +95,35 @@  (define-module (gnu packages telephony)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system qt))
 
+(define-public phonesim
+  (package
+    (name "phonesim")
+    (version "1.21")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.kernel.org/pub/scm/network/ofono/phonesim.git")
+                    (commit "a7c844d45b047b2dae5b0877816c346fce4c47b9")))
+              (sha256
+               (base32
+                "0rc1c2vr03dmi1dr3skj57v77ga9c22g29xs1qiphqms4isby9cq"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags
+       (list "--enable-maintainer-mode"
+             "CC=gcc")))
+    (native-inputs
+     `(("automake" ,automake)
+       ("autoconf" ,autoconf)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("qtbase" ,qtbase-5)
+       ("qtdeclarative" ,qtdeclarative)))
+    (synopsis "Phone Simulator for modem testing")
+    (description "Phone Simulator for modem testing")
+    (home-page "https://git.kernel.org/pub/scm/network/ofono/phonesim.git")
+    (license license:gpl2+)))
+
 (define-public libilbc
   (package
     (name "libilbc")