diff mbox series

[bug#51676] gnu: Add python-miniupnpc

Message ID 20211108034117.69082-1-singpolyma@singpolyma.net
State Accepted
Headers show
Series [bug#51676] gnu: Add python-miniupnpc | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Nov. 8, 2021, 3:41 a.m. UTC
* gnu/packages/python-xyz.scm (python-miniupnpc): New variable.
---
 gnu/packages/python-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

Ludovic Courtès Nov. 17, 2021, 3:33 p.m. UTC | #1
Hi Stephen,

Stephen Paul Weber <singpolyma@singpolyma.net> skribis:

> * gnu/packages/python-xyz.scm (python-miniupnpc): New variable.

[...]

> +    (version "2.2.3")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri
> +        (git-reference
> +         (url "https://github.com/miniupnp/miniupnp")
> +         (commit "36a65e3d841d4e85904fed690c0b755d5b380043")))

This commit:

--8<---------------cut here---------------start------------->8---
$ (cd /tmp/miniupnp/; git checkout 36a65e3d841d4e85904fed690c0b755d5b380043; git describe)
La posició de HEAD anterior era 2df8120 miniupnpc version 2.2.3
HEAD ara és a 36a65e3 miniupnpc/Changelog.txt: VERSION 2.2.3
miniupnpd_2_1-574-g36a65e3
--8<---------------cut here---------------end--------------->8---

… does not match the tag for 2.2.3:

--8<---------------cut here---------------start------------->8---
$ (cd /tmp/miniupnp/; git checkout miniupnpc_2_2_3; git log |head -1)
La posició de HEAD anterior era 36a65e3 miniupnpc/Changelog.txt: VERSION 2.2.3
HEAD ara és a 2df8120 miniupnpc version 2.2.3
commit 2df8120326ed4246e049a7a6de707539604cd514
--8<---------------cut here---------------end--------------->8---

> +    (description "A client library for Python programs to set up port forwards
> +using UPnP.")

Please make it a full sentence, as per:

  https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html

Could you send an updated patch that addresses these two issues?

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8ba72170c0..558e104cf1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3093,6 +3093,42 @@  server.")
      "@code{pafy} is a python library to retrieve YouTube content and metadata.")
     (license license:lgpl3+)))
 
+(define-public python-miniupnpc
+  (package
+    (name "python-miniupnpc")
+    (version "2.2.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/miniupnp/miniupnp")
+         (commit "36a65e3d841d4e85904fed690c0b755d5b380043")))
+       (file-name
+        (git-file-name name version))
+       (sha256
+        (base32 "0h7smsp1fnwsmgg3n70813ln9j5y20g61x25s4kn91vzkbbq9188"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'subdir
+           (lambda _
+             (chdir "miniupnpc")
+             (setenv "CC" ,(cc-for-target))
+             (substitute* "Makefile"
+               (("SH = /bin/sh") (string-append "SH = " (which "bash"))))
+             #t)))))
+    (inputs
+     `(("python" ,python))) ; We are building a Python extension.
+    (native-inputs
+     `(("which" ,which)))
+    (synopsis "UPnP client for Python")
+    (description "A client library for Python programs to set up port forwards
+using UPnP.")
+    (home-page "http://miniupnp.free.fr")
+    (license license:bsd-3)))
+
 (define-public python2-funcsigs
   (package
     (name "python2-funcsigs")