diff mbox series

[bug#51675,2/5] gnu: python-twisted: Update to 21.7.0

Message ID 20211108024520.49594-2-singpolyma@singpolyma.net
State New
Headers show
Series [bug#51675,1/5] gnu: python-incremental: Update to 21.3.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Nov. 8, 2021, 2:45 a.m. UTC
* gnu/packages/python-xyz.scm (python-twisted): Update to 21.7.0.
[propagated-inputs]: Add python-typing-extensions, python-attrs, and python-service-identity.
---
 gnu/packages/python-xyz.scm | 17 +++++++++++++----
 1 file changed, 13 insertions(+), 4 deletions(-)

Comments

Vinicius Monego Nov. 12, 2021, 5:53 p.m. UTC | #1
Hi,

Em dom, 2021-11-07 às 21:45 -0500, Stephen Paul Weber escreveu:
> * gnu/packages/python-xyz.scm (python-twisted): Update to 21.7.0.
> [propagated-inputs]: Add python-typing-extensions, python-attrs, and
> python-service-identity.
> ---

I did not try to build the series, I will comment based on some
impressions first.

>  gnu/packages/python-xyz.scm | 17 +++++++++++++----
>  1 file changed, 13 insertions(+), 4 deletions(-)
> 
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-
> xyz.scm
> index 639945c278..96718c7c18 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -15105,22 +15105,31 @@ format.")
>  (define-public python-twisted
>    (package
>      (name "python-twisted")
> -    (version "19.7.0")
> +    (version "21.7.0")
>      (source (origin
>                (method url-fetch)
> -              (uri (pypi-uri "Twisted" version ".tar.bz2"))
> +              (uri (pypi-uri "Twisted" version))

This change should be described in the commit message.

>                (sha256
>                 (base32
> -               
> "17d3hnxv9qndagzz63mdpyk99xj63p9gq586vjn0rxk8cl197nym"))))
> +               
> "01lh225d7lfnmfx4f4kxwl3963gjc9yg8jfkn1w769v34ia55mic"))))
>      (build-system python-build-system)
>      (arguments
> -     '(#:tests? #f))                    ; FIXME: some tests fail
> +     '(#:tests? #f ; FIXME: some tests fail
> +       #:phases (modify-phases %standard-phases
> +                  (add-after 'unpack 'add-py3-var
> +                    (lambda _
> +                      (substitute* "src/twisted/python/compat.py"
> +                        (("_PY37PLUS = True")
> +                         "_PY37PLUS = True\n    _PY3 = True")))))))

This new phase should be described in the commit message.

>      (propagated-inputs
>       `(("python-zope-interface" ,python-zope-interface)
>         ("python-pyhamcrest" ,python-pyhamcrest)
>         ("python-incremental" ,python-incremental)
>         ("python-hyperlink" ,python-hyperlink)
>         ("python-constantly" ,python-constantly)
> +       ("python-typing-extensions" ,python-typing-extensions)
> +       ("python-attrs" ,python-attrs)
> +       ("python-service-identity" ,python-service-identity)
>         ("python-automat" ,python-automat)))

Could you also sort these inputs alphabetically?

>      (home-page "https://twistedmatrix.com/")
>      (synopsis "Asynchronous networking framework written in Python")
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 639945c278..96718c7c18 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15105,22 +15105,31 @@  format.")
 (define-public python-twisted
   (package
     (name "python-twisted")
-    (version "19.7.0")
+    (version "21.7.0")
     (source (origin
               (method url-fetch)
-              (uri (pypi-uri "Twisted" version ".tar.bz2"))
+              (uri (pypi-uri "Twisted" version))
               (sha256
                (base32
-                "17d3hnxv9qndagzz63mdpyk99xj63p9gq586vjn0rxk8cl197nym"))))
+                "01lh225d7lfnmfx4f4kxwl3963gjc9yg8jfkn1w769v34ia55mic"))))
     (build-system python-build-system)
     (arguments
-     '(#:tests? #f))                    ; FIXME: some tests fail
+     '(#:tests? #f ; FIXME: some tests fail
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'add-py3-var
+                    (lambda _
+                      (substitute* "src/twisted/python/compat.py"
+                        (("_PY37PLUS = True")
+                         "_PY37PLUS = True\n    _PY3 = True")))))))
     (propagated-inputs
      `(("python-zope-interface" ,python-zope-interface)
        ("python-pyhamcrest" ,python-pyhamcrest)
        ("python-incremental" ,python-incremental)
        ("python-hyperlink" ,python-hyperlink)
        ("python-constantly" ,python-constantly)
+       ("python-typing-extensions" ,python-typing-extensions)
+       ("python-attrs" ,python-attrs)
+       ("python-service-identity" ,python-service-identity)
        ("python-automat" ,python-automat)))
     (home-page "https://twistedmatrix.com/")
     (synopsis "Asynchronous networking framework written in Python")