diff mbox series

[bug#51280,v2,4/5] gnu: openttd-openmsx: Update to 0.4.2.

Message ID 20211106104040.34751-5-felgru@posteo.net
State Accepted
Headers show
Series Update openttd to 12.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber Nov. 6, 2021, 10:40 a.m. UTC
* packages/games.scm (openttd-openmsx): Update to 0.4.2.
  [native-inputs]: Replace python-2 with python.
---
 gnu/packages/games.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Liliana Marie Prikler Nov. 6, 2021, 12:34 p.m. UTC | #1
Hi,

Am Samstag, den 06.11.2021, 10:40 +0000 schrieb Felix Gruber:
> * packages/games.scm (openttd-openmsx): Update to 0.4.2.
>   [native-inputs]: Replace python-2 with python.
> ---
>  gnu/packages/games.scm | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index a6602fe4f6..8e92e04daa 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -4433,7 +4433,7 @@ the original Transport Tycoon Deluxe.")
>  (define openttd-openmsx
>    (package
>      (name "openttd-openmsx")
> -    (version "0.4.0")
> +    (version "0.4.2")
>      (source
>       (origin
>         (method url-fetch)
> @@ -4442,11 +4442,11 @@ the original Transport Tycoon Deluxe.")
>               version "/openmsx-" version "-source.tar.xz"))
>         (sha256
>          (base32
> -         "0prjljsdgdxqdhhcriqskqha004ybs575xcjq80zha3pqnmrdk0k"))))
> +         "0h583d8fxy78kc3jvpp78r76a48qhxrhm4q7jbnj74aw0kwrcl8g"))))
>      (build-system gnu-build-system)
>      (native-inputs
>       `(("grfcodec" ,grfcodec)
> -       ("python" ,python-2)
> +       ("python" ,python)
>         ("tar" ,tar)))
>      (arguments
>       `(#:make-flags
OpenTTD fails to find this version of opensmx (as opposed to failing to
play any sound for it, which is the current behaviour on master).  Do
you have a guess as to why this is the case?

Regards,
Liliana
Liliana Marie Prikler Nov. 6, 2021, 12:34 p.m. UTC | #2
Am Samstag, den 06.11.2021, 13:34 +0100 schrieb Liliana Marie Prikler:
> OpenTTD fails to find this version of opensmx
Should be openmsx, always typo on that one
Felix Gruber Nov. 7, 2021, 8:06 p.m. UTC | #3
Hi Liliana,

On 11/6/21 1:34 PM, Liliana Marie Prikler wrote:
> OpenTTD fails to find this version of opensmx (as opposed to failing to
> play any sound for it, which is the current behaviour on master).  Do
> you have a guess as to why this is the case?

It looks like the script that generates the midi files in openmsx
silently failed after I've replaced the python2 native-input with
python, because the Python scripts in openmsx refer in their #! to
Python as python and not python3. When I instead use the native-input
python-wrapper, the midi files are correctly built and we are back to
the old behaviour with openttd showing the midi tracks but being unable
to play them.

I'll send an updated patch for openmsx.

Best,
Felix
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a6602fe4f6..8e92e04daa 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4433,7 +4433,7 @@  the original Transport Tycoon Deluxe.")
 (define openttd-openmsx
   (package
     (name "openttd-openmsx")
-    (version "0.4.0")
+    (version "0.4.2")
     (source
      (origin
        (method url-fetch)
@@ -4442,11 +4442,11 @@  the original Transport Tycoon Deluxe.")
              version "/openmsx-" version "-source.tar.xz"))
        (sha256
         (base32
-         "0prjljsdgdxqdhhcriqskqha004ybs575xcjq80zha3pqnmrdk0k"))))
+         "0h583d8fxy78kc3jvpp78r76a48qhxrhm4q7jbnj74aw0kwrcl8g"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("grfcodec" ,grfcodec)
-       ("python" ,python-2)
+       ("python" ,python)
        ("tar" ,tar)))
     (arguments
      `(#:make-flags