diff mbox series

[bug#51396,v2,1/8] gnu: python-aws-sam-translator: Update to 1.40.0.

Message ID 20211105015836.1046845-1-monego@posteo.net
State Accepted
Headers show
Series Update python-moto. | expand

Commit Message

Vinicius Monego Nov. 5, 2021, 1:58 a.m. UTC
* gnu/packages/python-web.scm (python-aws-sam-translator): Update to 1.40.0.
[arguments]<#:phases>: Don't return #t.
[home-page]: Follow redirect.
---
 gnu/packages/python-web.scm | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)


base-commit: 142344b6efa42e1a4d57a4bdf14dfb3ca1cba25a
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 62de043e70..29c0b7e15e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -394,13 +394,13 @@  WSGI.  This package includes libraries for implementing ASGI servers.")
 (define-public python-aws-sam-translator
   (package
     (name "python-aws-sam-translator")
-    (version "1.38.0")
+    (version "1.40.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "aws-sam-translator" version))
               (sha256
                (base32
-                "1djwlsjpbh13m4biglimrm9lq7hmla0k29giay7k3cjsrylxvjhf"))))
+                "1hq5ggbzcq4k3ks439hki493w4sasgaxns6j5x57xsj822acalmf"))))
     (build-system python-build-system)
     (arguments
      `(;; XXX: Tests are not distributed with the PyPI archive, and would
@@ -413,13 +413,12 @@  WSGI.  This package includes libraries for implementing ASGI servers.")
                       ;; of dependencies, when it works fine with others.
                       (substitute* "requirements/base.txt"
                         (("(.*)(~=[0-9\\.]+)" all package version)
-                         package))
-                      #t)))))
+                         package)))))))
     (propagated-inputs
      `(("python-boto3" ,python-boto3)
        ("python-jsonschema" ,python-jsonschema)
        ("python-six" ,python-six)))
-    (home-page "https://github.com/awslabs/serverless-application-model")
+    (home-page "https://github.com/aws/serverless-application-model")
     (synopsis "Transform AWS SAM templates into AWS CloudFormation templates")
     (description
      "AWS SAM Translator is a library that transform @dfn{Serverless Application