diff mbox series

[bug#51208,v2,2/2] gnu: Add whipper.

Message ID 20211101180325.230033-2-monego@posteo.net
State New
Headers show
Series [bug#51208,v2,1/2] gnu: Add python-pycdio. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Nov. 1, 2021, 6:03 p.m. UTC
* gnu/packages/cdrom.scm (whipper): New variable.
---
Moved propagated inputs to normal inputs and removed gobject-introspection from native-inputs.

 gnu/packages/cdrom.scm | 58 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 58 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 5551536408..b8a95a3b15 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -69,9 +69,12 @@ 
   #:use-module (gnu packages base)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages perl-web)
+  #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages image)
   #:use-module (gnu packages photo)
+  #:use-module (gnu packages serialization)
   #:use-module (gnu packages swig)
   #:use-module (gnu packages tcl)
   #:use-module (gnu packages video)
@@ -639,6 +642,61 @@  from an audio CD.")
 (CD Input and Control library).")
     (license gpl3+)))
 
+(define-public whipper
+  (package
+    (name "whipper")
+    (version "0.10.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/whipper-team/whipper")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "00cq03cy5dyghmibsdsq5sdqv3bzkzhshsng74bpnb5lasxp3ia5"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'cdparanoia
+           ;; Fix cdparanoia executable name.
+           (lambda _
+             (substitute* "whipper/program/cdparanoia.py"
+               (("cd-paranoia") "cdparanoia"))))
+         (add-before 'check 'set-home
+           (lambda _
+             (setenv "HOME" (getcwd)))) ; tests need a writable home
+         (add-before 'check 'skip-failing-test
+           ;; This test apparently relies on live data that changes over time:
+           ;; https://github.com/whipper-team/whipper/issues/515.
+           (lambda _
+             (substitute* "whipper/test/test_common_accurip.py"
+               (("test_AccurateRipResponse_parses_correctly")
+                "_test_AccurateRipResponse_parses_correctly")))))))
+    (native-inputs
+     `(("python-setuptools-scm" ,python-setuptools-scm)
+       ("python-twisted" ,python-twisted)))
+    (inputs
+     `(("cdparanoia" ,cdparanoia)
+       ("cdrdao" ,cdrdao)
+       ("flac" ,flac)
+       ("libdiscid" ,libdiscid)
+       ("libsndfile" ,libsndfile)
+       ("python-discid" ,python-discid)
+       ("python-musicbrainzngs" ,python-musicbrainzngs)
+       ("python-mutagen" ,python-mutagen)
+       ("python-pycdio" ,python-pycdio)
+       ("python-pygobject" ,python-pygobject)
+       ("python-ruamel.yaml" ,python-ruamel.yaml)
+       ("sox" ,sox)))
+    (home-page "https://github.com/whipper-team/whipper")
+    (synopsis "CD-DA ripper preferring accuracy over speed")
+    (description "Whipper is a CD-DA ripper forked from the morituri project
+(CDDA ripper aiming for accuracy over speed), which development seems to have
+halted.")
+    (license gpl3+)))
+
 (define-public abcde
   (package
     (name "abcde")