diff mbox series

[bug#48263,v2,1/3] gnu: python-hypercorn: Remove "python-" prefix from name.

Message ID 20211030173048.53815-1-monego@posteo.net
State Accepted
Headers show
Series [bug#48263,v2,1/3] gnu: python-hypercorn: Remove "python-" prefix from name. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Oct. 30, 2021, 5:30 p.m. UTC
Hypercorn is mainly a CLI application but also supports a module interface.

* gnu/packages/python-web.scm (python-hypercorn): New deprecated variable.
(hypercorn): Renamed from the respective above.
---
 gnu/packages/python-web.scm | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)


base-commit: e1261ddd38cf02a0f046f3a5360502d659b4e7d4

Comments

Efraim Flashner Nov. 8, 2021, 8:38 p.m. UTC | #1
Thanks! Patch pushed.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 2b5379950d..7a4e62ddf6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1615,9 +1615,9 @@  choose to use, ensuring that you can communicate via WebSockets, as defined in
 RFC6455, regardless of your programming paradigm.")
     (license license:expat)))
 
-(define-public python-hypercorn
+(define-public hypercorn
   (package
-    (name "python-hypercorn")
+    (name "hypercorn")
     (version "0.10.2")
     (source
      (origin
@@ -1633,6 +1633,7 @@  RFC6455, regardless of your programming paradigm.")
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (add-installed-pythonpath inputs outputs)
              (invoke "pytest" "-vv"))))))
+    ;; Propagate because Hypercorn also exposes functionality over a module.
     (propagated-inputs
      `(("python-h11" ,python-h11)
        ("python-h2" ,python-h2)
@@ -1657,6 +1658,9 @@  WebSockets (over HTTP/1 and HTTP/2), ASGI/2, and ASGI/3 specifications.  It can
 utilise asyncio, uvloop, or trio worker types.")
     (license license:expat)))
 
+(define-public python-hypercorn
+  (deprecated-package "python-hypercorn" hypercorn))
+
 (define-public python-querystring-parser
   (package
     (name "python-querystring-parser")