diff mbox series

[bug#51500] gnu: Add kiwix-tools

Message ID 20211030053631.31209-1-GNUtoo@cyberdimension.org
State Accepted
Headers show
Series [bug#51500] gnu: Add kiwix-tools | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Denis 'GNUtoo' Carikli Oct. 30, 2021, 5:36 a.m. UTC
* gnu/packages/web.scm (kiwix-tools): New variable.

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
 gnu/packages/web.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)

Comments

Denis 'GNUtoo' Carikli Oct. 30, 2021, 5:51 a.m. UTC | #1
Hi,

Last time I sent a patch I was told that "by convention we keep [the
signed-off-by] for the person who applies the patch.".

Does it means that next times I send patches, it's better if I do not
add my signed-off-by at all?

Or is it better if I leave it and that it get stripped by the person
who merge the patch each time as through that way way I also formally
signed the developer certificate of origin, and even if it's stripped
it offers more guarantees.

Denis.
Denis 'GNUtoo' Carikli Dec. 7, 2021, 5:14 p.m. UTC | #2
Hi,

It's been (way) more than two weeks so I can safely ping.

Denis.
Leo Famulari Dec. 7, 2021, 10:41 p.m. UTC | #3
On Sat, Oct 30, 2021 at 07:51:56AM +0200, Denis 'GNUtoo' Carikli wrote:
> Last time I sent a patch I was told that "by convention we keep [the
> signed-off-by] for the person who applies the patch.".
> 
> Does it means that next times I send patches, it's better if I do not
> add my signed-off-by at all?

Right. In Guix, we used the "signed-off-by" line to say who pushed the
patch on behalf of its author.

This information is actually always there in the Git history, but it's
not shown unless you add '--format=full' to commands such as `git log`
and `git show`.

And of course, the ultimate source of truth about who pushed the patch
is contained in the PGP signature of the commit, shown with a command
such as `git show --show-signature 9e67f2ad418e9a5a7a83`.

So, using "signed-off-by" in this way is just for convenience, for
anyone reading the log. This convention is described in the manual
section Commit Access:

https://guix.gnu.org/manual/en/html_node/Commit-Access.html#Commit-Access

> Or is it better if I leave it and that it get stripped by the person
> who merge the patch each time as through that way way I also formally
> signed the developer certificate of origin, and even if it's stripped
> it offers more guarantees.

You can do as you like, but adding the line "signed-off-by" to your
patches does not communicate anything related to copyright ownership or
licensing.

It's assumed that you are sharing your patches under the license used by
Guix, and that you have the right to do so. If it happens that we accept
a contribution that does not meet those criteria, we will remove it from
Guix, as part of our "Commitment to Correct Mistakes", which is part of
the Free System Distribution Guidelines that we follow:

https://www.gnu.org/distros/free-system-distribution-guidelines.en.html
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index d7df3079b3..c775610634 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -8124,6 +8124,44 @@  (define-public kiwix-desktop
 offline (such as Wikipedia), without any access to Internet.")
     (license license:gpl3)))
 
+(define-public kiwix-tools
+  (package
+    (name "kiwix-tools")
+    (version "3.1.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://download.kiwix.org/release/kiwix-tools/kiwix-tools-"
+                    version
+                    ".tar.xz"))
+              (sha256
+               (base32
+                "1npf9ddhpkmx97gxmvmwmi8a69md8kh2szimd9rpg6ggd4big03a"))))
+    (build-system meson-build-system)
+    (inputs
+     `(("curl" ,curl)
+       ("icu4c" ,icu4c)
+       ("kiwix-lib" ,kiwix-lib)
+       ("libmicrohttpd" ,libmicrohttpd)
+       ("libzim" ,libzim)
+       ("pugixml" ,pugixml)
+       ("xapian" ,xapian)
+       ("zlib" ,zlib)
+       ("zstd" ,zstd "lib")))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://wiki.kiwix.org/wiki/Software")
+    (synopsis "Kiwix command line tools")
+    (description "The Kiwix tools is a collection of Kiwix related command line
+tools:
+@itemize
+@item kiwix-manage: Manage XML based library of ZIM files
+@item kiwix-read: Read ZIM file content
+@item kiwix-search: Fulltext search in ZIM files
+@item kiwix-serve: HTTP daemon serving ZIM files
+@end itemize\n")
+    (license license:gpl3)))
+
 (define-public uriparser
   (let ((commit "25dddb16cf044a7df27884e7ad3911baaaca3d7c")
         (revision "1"))