diff mbox series

[bug#51467,core-updates-frozen] gnu: gtk+: Fix testsuite failure on non-x86_64 platforms.

Message ID 20211028194323.50370-1-bauermann@kolabnow.com
State Accepted
Headers show
Series [bug#51467,core-updates-frozen] gnu: gtk+: Fix testsuite failure on non-x86_64 platforms. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Thiago Jung Bauermann Oct. 28, 2021, 7:43 p.m. UTC
On non-x86_64 platforms, gtk+ is linked with a gdk-pixbuf version that
doesn’t support SVG.  This causes the ‘tree-relationships’ test to fail
because it tries to fetch SVG icons in some of the tests.

Therefore, we need to disable the test when SVG support isn’t available.

* gnu/packages/gtk.scm (gtk+)[arguments]<#:phases>{disable-failing-tests}:
Disable ‘tree-relationships’ test on non-x86_64 platforms.
---

Hello,

Considering that the core-updates-frozen-batched-changes branch will
soon make GTK+ depend on Rust (via an updated mozjs package), perhaps
this patch is somewhat pointless. But I thought it would be at least a
bit useful to have this information recorded.

Also, there's a good change that polkit will switch from mozjs to duktape
as its Javascript engine. In that case it will be useful again to have
this patch in.

With this patch, GTK+ builds again on core-updates-frozen on
powerpc64le-linux. This patch doesn't change the package derivation
on x86_64-linux

Thanks,
Thiago.

 gnu/packages/gtk.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Maxim Cournoyer Nov. 12, 2021, 6:05 a.m. UTC | #1
Thiago Jung Bauermann <bauermann@kolabnow.com> writes:

> On non-x86_64 platforms, gtk+ is linked with a gdk-pixbuf version that
> doesn’t support SVG.  This causes the ‘tree-relationships’ test to fail
> because it tries to fetch SVG icons in some of the tests.
>
> Therefore, we need to disable the test when SVG support isn’t available.
>
> * gnu/packages/gtk.scm (gtk+)[arguments]<#:phases>{disable-failing-tests}:
> Disable ‘tree-relationships’ test on non-x86_64 platforms.

Mathieu applied it on core-updates(-frozen) with commit
b452fe87e0c6e7634a2cb44274fa46832c763b40.

Closing.

Thank you!

Maxim
Thiago Jung Bauermann Nov. 17, 2021, 12:56 a.m. UTC | #2
Hello again,

Em sexta-feira, 12 de novembro de 2021, às 11:45:43 -03, Thiago Jung 
Bauermann escreveu:
> This patch disables the ‘tree-relationships’ test, and it’s not yet
> applied on core-updates-frozen so I’m reopening the bug report.

Strange, I recently built gtk+ on core-updates-frozen (commit ef77c3b3f120) 
on powerpc64le-linux and  the ‘tree-relationships’ test passed!

I don’t understand what is different this time, but it looks like this patch 
isn’t necessary anymore.

Closing again.
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index fadd0794c5dd..40fc2c93d681 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1106,7 +1106,12 @@  (define-public gtk+
                      '()))
              (substitute* "testsuite/a11y/Makefile.in"
                (("accessibility-dump tree-performance text children derive")
-                "tree-performance text children derive"))
+                "tree-performance text children derive")
+               ;; The ‘tree-relationships’ test needs SVG support.
+               ,@(if (not (target-x86-64?))
+                     '((("value misc tree-relationships util")
+                        "value misc util"))
+                     '()))
              (substitute* "testsuite/reftests/Makefile.in"
                (("TEST_PROGS = gtk-reftest")
                 "TEST_PROGS = "))