diff mbox series

[bug#51464,2/2] gnu: Add r-xnastring.

Message ID 20211028182609.1880-2-madalinionel.patrascu@mdc-berlin.de
State Accepted
Headers show
Series [bug#51464,1/2] gnu: Add r-formattable. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu Oct. 28, 2021, 6:26 p.m. UTC
* gnu/packages/bioconductor.scm (r-xnastring): New variable.
---
 gnu/packages/bioconductor.scm | 44 +++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 90a0e1f288..abb5b7065d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -4627,6 +4627,50 @@  (define-public r-vsn
 and specific in detecting differential transcription.")
     (license license:artistic2.0)))
 
+(define-public r-xnastring
+  (package
+    (name "r-xnastring")
+    (version "1.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "XNAString" version))
+       (sha256
+        (base32 "1rpcvn54a6s3iwmdg96rshilr1mqcb1nlbvzbyp5xi55km7iwm8i"))))
+    (properties `((upstream-name . "XNAString")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biostrings" ,r-biostrings)
+       ("r-bsgenome" ,r-bsgenome)
+       ("r-data-table" ,r-data-table)
+       ("r-formattable" ,r-formattable)
+       ("r-future-apply" ,r-future-apply)
+       ("r-genomicranges" ,r-genomicranges)
+       ("r-htmltools" ,r-htmltools)
+       ("r-htmlwidgets" ,r-htmlwidgets)
+       ("r-iranges" ,r-iranges)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rmarkdown" ,r-rmarkdown)
+       ("r-s4vectors" ,r-s4vectors)
+       ("r-stringi" ,r-stringi)
+       ("r-stringr" ,r-stringr)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://git.bioconductor.org/packages/XNAString")
+    (synopsis "Manipulation of modified oligonucleotide sequences")
+    (description
+     "The R @code{XNAString} package allows for description of base sequences
+and associated chemical modifications in a single object.  XNAString is able to
+capture single stranded, as well as double stranded molecules.  Chemical
+modifications are represented as independent strings associated with different
+features of the molecules (base sequence, sugar sequence, backbone sequence,
+modifications) and can be read or written to a @dfn{Hierarchical Editing
+Language for Macromolecules} (HELM) notation.  It also enables secondary
+structure prediction using RNAfold from ViennaRNA.  XNAString is designed to be
+efficient representation of nucleic-acid based therapeutics, therefore it
+stores information about target sequences and provides interface for matching
+and alignment functions from Biostrings package.")
+    (license license:gpl2)))
+
 (define-public r-xvector
   (package
     (name "r-xvector")