diff mbox series

[bug#51418,1/2] gnu: Add python-ipaddress.

Message ID 20211026192859.875-1-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#51418,1/2] gnu: Add python-ipaddress. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

paul Oct. 26, 2021, 7:28 p.m. UTC
* gnu/packages/python-xyz.scm (python-ipaddress): New variable;
(python2-ipaddress): Use package-with-python2.
---
 gnu/packages/python-xyz.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)


base-commit: c6adc0947396daa6d85ab08837f9cbc86f4d8722

Comments

paul Oct. 26, 2021, 7:33 p.m. UTC | #1
Dear all,

I apologize this should be merged with 51419 . Is there a way to merge 
two tickets from issues.guix.gnu.org?

Thank you,

giacomo
Tobias Geerinckx-Rice Oct. 26, 2021, 7:59 p.m. UTC | #2
Giacomo,

> Is there a way to merge two tickets from issues.guix.gnu.org?

Yes.  See my simple mail doing just that at 
https://issues.guix.gnu.org/51419#1

You can find the special recipient address and more information at 
https://debbugs.gnu.org/server-control.html

Kind regards,

T G-R
paul Oct. 26, 2021, 8:58 p.m. UTC | #3
Dear Tobias,

thank you, for merging.

On 10/26/21 9:59 PM, Tobias Geerinckx-Rice wrote:
> You can find the special recipient address and more information at 
> https://debbugs.gnu.org/server-control.html

This is very useful, thanks!

giacomo
Ludovic Courtès Dec. 11, 2021, 10:39 p.m. UTC | #4
Hi,

Giacomo Leidi <goodoldpaul@autistici.org> skribis:

> * gnu/packages/python-xyz.scm (python-ipaddress): New variable;
> (python2-ipaddress): Use package-with-python2.

[...]

> * gnu/packages/python-xyz.scm (python-vcrpy): Update to 4.1.1.
> [arguments]: Replace 'check phase to run unit tests.
> [native-inputs]: Add required dependencies.

This had fallen through the cracks but it’s been applied now.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a7b1e0efe2..48404b441a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11159,9 +11159,9 @@  (define-public python-pyasn1-modules
 (define-public python2-pyasn1-modules
   (package-with-python2 python-pyasn1-modules))
 
-(define-public python2-ipaddress
+(define-public python-ipaddress
   (package
-    (name "python2-ipaddress")
+    (name "python-ipaddress")
     (version "1.0.23")
     (source (origin
               (method url-fetch)
@@ -11170,17 +11170,17 @@  (define-public python2-ipaddress
                (base32
                 "1qp743h30s04m3cg3yk3fycad930jv17q7dsslj4mfw0jlvf1y5p"))))
     (build-system python-build-system)
-    (arguments
-     `(#:python ,python-2))
     (home-page "https://github.com/phihag/ipaddress")
     (synopsis "IP address manipulation library")
     (description
       "This package provides a fast, lightweight IPv4/IPv6 manipulation library
  in Python.  This library is used to create, poke at, and manipulate IPv4 and
- IPv6 addresses and networks.  This is a port of the Python 3.3 ipaddress
- module to older versions of Python.")
+ IPv6 addresses and networks.")
     (license license:psfl)))
 
+(define-public python2-ipaddress
+  (package-with-python2 python-ipaddress))
+
 (define-public python-asn1tools
   (package
     (name "python-asn1tools")