diff mbox series

[bug#51414] gnu: Update patchage.

Message ID 20211026131240.13178-1-t_w_@freenet.de
State New
Headers show
Series [bug#51414] gnu: Update patchage. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thorsten Wilms Oct. 26, 2021, 1:12 p.m. UTC
* gnu/packages/audio.scm (patchage): Update, no argument about python-2, use system fmt instead of bundled, fix homepage link.
---
 gnu/packages/audio.scm | 15 ++++++++-------
 1 file changed, 8 insertions(+), 7 deletions(-)

Comments

Vagrant Cascadian Sept. 1, 2023, 9:07 p.m. UTC | #1
On 2021-10-26, Thorsten Wilms wrote:
> @@ -2842,7 +2843,7 @@ (define-public freealut
>  (define-public patchage
>    (package
>      (name "patchage")
> -    (version "1.0.2")
> +    (version "1.0.4")

patchage is currently at version 1.0.10, marking as done.


live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index faf106fc68..b377126777 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@ 
 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -99,6 +99,7 @@  (define-module (gnu packages audio)
   #:use-module (gnu packages onc-rpc)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages pretty-print) ; fmt
   #:use-module (gnu packages pulseaudio)  ;libsndfile, libsamplerate
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
@@ -2842,7 +2843,7 @@  (define-public freealut
 (define-public patchage
   (package
     (name "patchage")
-    (version "1.0.2")
+    (version "1.0.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://download.drobilla.net/patchage-"
@@ -2850,11 +2851,10 @@  (define-public patchage
                                   ".tar.bz2"))
               (sha256
                (base32
-                "0dk3fiac10m83mwss3026yz7ygc47c2iw924cwwnh2fyydc9bsy6"))))
+                "0gbakiw3mikgbvy3pssrmqmn7z5c7kp4vyaxj5rs4jnkscxgw9vw"))))
     (build-system waf-build-system)
     (arguments
-     `(#:tests? #f                      ; no check target
-       #:python ,python-2))
+     `(#:tests? #f)) ; no check target
     (inputs
      `(("alsa-lib" ,alsa-lib)
        ("boost" ,boost)
@@ -2862,10 +2862,11 @@  (define-public patchage
        ("ganv" ,ganv)
        ("glibmm" ,glibmm)
        ("gtkmm" ,gtkmm-2)
-       ("dbus-glib" ,dbus-glib)))
+       ("dbus-glib" ,dbus-glib)
+       ("fmt" ,fmt)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
-    (home-page "https://drobilla.net/software/patchage/")
+    (home-page "https://drobilla.net/software/patchage.html")
     (synopsis "Modular patch bay for audio and MIDI systems")
     (description
      "Patchage is a modular patch bay for audio and MIDI systems based on JACK