diff mbox series

[bug#49008,v2] gnu: Add invada-studio-plugins-lv2.

Message ID 20211026124050.11299-1-t_w_@freenet.de
State New
Headers show
Series [bug#49008,v2] gnu: Add invada-studio-plugins-lv2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thorsten Wilms Oct. 26, 2021, 12:40 p.m. UTC
* gnu/packages/audio.scm (invada-studio-plugins-lv2): New Varaible.
---
 gnu/packages/audio.scm | 45 +++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 44 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index faf106fc68..62e8a0532a 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@ 
 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018. 2021 Thorsten Wilms <t_w_@freenet.de>
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -5566,3 +5566,46 @@  (define-public mda-lv2
      "MDA-LV2 is an LV2 port of the MDA plugins.  It includes effects and a few
 instrument plugins.")
     (license license:gpl3+)))
+
+(define-public invada-studio-plugins-lv2
+  (package
+    (name "invada-studio-plugins-lv2")
+    (version "1.3pre")
+    ;; Last release 1.2 is from 2009 and lacks required changes.
+    (source (origin
+              (method bzr-fetch)
+              (uri (bzr-reference
+		    (url "lp:invada-studio")
+		    (revision "108")))
+              (sha256
+               (base32
+		"05flf9b25z14380b54z47jvnbyilq24arm6jysk29zmxq28a6d3l"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; no check target
+       #:phases
+       (modify-phases
+	   %standard-phases         
+	 (delete 'configure) ; There is no configure script
+	 (add-after 'unpack 'adjust-makefile
+	   (lambda* (#:key outputs #:allow-other-keys)
+	     (substitute* "Makefile"
+	       ;; Set proper LV2 plugin target directory:
+	       (("/usr/local")
+		(assoc-ref outputs "out"))
+	       ;; The default install target just prints a note about
+	       ;; install-user and install-sys, the one we want:
+	       (("install:") "install: install-sys"))
+	     #t)))))
+    (inputs
+     `(("lv2" ,lv2)
+       ("gtk" ,gtk+-2)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://launchpad.net/invada-studio/lv2")
+    (synopsis "LV2 audio plugin collection.")
+    (description
+     "Invada Studio Plugins are LV2 audio plugins, including distortion, delay, 
+compressor, filters, Phasers, early-reflections-based reverb, utility and test
+tone generator. ")
+    (license (list license:gpl2+ license:gpl2+))))