diff mbox series

[bug#49224,v2] gnu: Add distrho-ports-lv2.

Message ID 20211026081831.7438-1-t_w_@freenet.de
State New
Headers show
Series [bug#49224,v2] gnu: Add distrho-ports-lv2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thorsten Wilms Oct. 26, 2021, 8:18 a.m. UTC
* gnu/packages/audio.scm (distrho-ports-lv2): New variable.
---
This time without superfluous search-path-specification and with proper
indentation.

 gnu/packages/audio.scm | 40 +++++++++++++++++++++++++++++++++++++++-
 1 file changed, 39 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index faf106fc68..d6ed470435 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -15,7 +15,7 @@ 
 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2018, 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018, 2021 Thorsten Wilms <t_w_@freenet.de>
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -5566,3 +5566,41 @@  (define-public mda-lv2
      "MDA-LV2 is an LV2 port of the MDA plugins.  It includes effects and a few
 instrument plugins.")
     (license license:gpl3+)))
+
+(define-public distrho-ports-lv2
+  (package
+    (name "distrho-ports-lv2")
+    (version "2021-03-15")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+	(string-append "https://github.com/DISTRHO/DISTRHO-Ports/archive/refs/tags/"
+                       version ".tar.gz"))
+       (sha256
+	(base32 "0cl10zvmg4zkiapza8aqj8p0brsfacvrxsr1fc7yy0b521q40xbj"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:configure-flags
+       (list
+	"-Dbuild-vst2=false"
+	"-Dbuild-vst3=false"
+	(string-append "--prefix=" (assoc-ref %outputs "out")))))
+    (inputs
+     `(("alsa" ,alsa-lib)
+       ("fftwf" ,fftwf)
+       ("freetype" ,freetype)
+       ("libx11" ,libx11)
+       ("libxcursor" ,libxcursor)
+       ("libxext" ,libxext)
+       ("lv2" ,lv2)
+       ("mesa" ,mesa)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://distrho.sourceforge.io/ports.php")
+    (synopsis "Audio plug-in pack for LV2")
+    (description
+     "DISTHRO Ports is a collection of LV2-versions of audio plugins that have
+been made with the JUCE-framework.")
+    ;; non-copyleft for drow (MIT). agpl3 for HiReSam.
+    (license (list license:gpl2 license:gpl2+ license:gpl3+ license:agpl3 license:non-copyleft))))