diff mbox series

[bug#50021,v2,2/8] gnu: Add python-iniparse.

Message ID 20211025231615.73660-2-monego@posteo.net
State Accepted
Headers show
Series [bug#50021,v2,1/8] gnu: Add python-phply. | expand

Commit Message

Vinicius Monego Oct. 25, 2021, 11:16 p.m. UTC
* gnu/packages/python-xyz.scm (python-iniparse): New variable.
---
 gnu/packages/python-xyz.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 84ead833eb..e025f7b87b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18490,6 +18490,38 @@  current test, while only declaring the test-specific fields")
 written in PLY.")
     (license license:bsd-3)))
 
+(define-public python-iniparse
+  (package
+    (name "python-iniparse")
+    (version "0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "iniparse" version))
+       (sha256
+        (base32 "0hm8784r25l5wrl274x65329l0b7pq3vfyq10jssrrr6slwm4blk"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ;; FIXME: Some tests are failing.
+    (propagated-inputs
+     `(("python-six" ,python-six)))
+    (home-page "https://github.com/candlepin/python-iniparse")
+    (synopsis "Accessing and Modifying INI files")
+    (description "@code{iniparse} is a INI parser for Python which is:
+
+@itemize
+@item Compatible with ConfigParser: Backward compatible implementations of
+ConfigParser, RawConfigParser, and SafeConfigParser are included that are
+API-compatible with the Python standard library.
+@item Preserves structure of INI files: Order of sections & options,
+indentation, comments, and blank lines are preserved as far as possible
+when data is updated.
+@item More convenient: Values can be accessed using dotted notation
+(@code{cfg.user.name}), or using container syntax
+(@code{cfg['user']['name']).}
+@end itemize")
+    (license license:expat)))
+
 (define-public python-translate-toolkit
   (package
     (name "python-translate-toolkit")