diff mbox series

[bug#50021,v2,1/8] gnu: Add python-phply.

Message ID 20211025231615.73660-1-monego@posteo.net
State Accepted
Headers show
Series [bug#50021,v2,1/8] gnu: Add python-phply. | expand

Commit Message

Vinicius Monego Oct. 25, 2021, 11:16 p.m. UTC
* gnu/packages/python-xyz.scm (python-phply): New variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)


base-commit: e1261ddd38cf02a0f046f3a5360502d659b4e7d4
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eb9fcc310d..84ead833eb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18469,6 +18469,27 @@  current test, while only declaring the test-specific fields")
 (define-public python2-factory-boy
   (package-with-python2 python-factory-boy))
 
+(define-public python-phply
+  (package
+    (name "python-phply")
+    (version "1.2.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "phply" version))
+       (sha256
+        (base32 "0gwz4j0pp479bwg6iwk7kcdbr1s4x9fikqri0b4ddn7vi198fibx"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-nose" ,python-nose)))
+    (propagated-inputs
+     `(("python-ply" ,python-ply)))
+    (home-page "https://github.com/viraptor/phply")
+    (synopsis "Lexer and parser for PHP")
+    (description "@code{phply} is a parser for the PHP programming language
+written in PLY.")
+    (license license:bsd-3)))
+
 (define-public python-translate-toolkit
   (package
     (name "python-translate-toolkit")