diff mbox series

[bug#51396,5/7] gnu: Update awscli, python-boto3 and python-botocore.

Message ID 20211025195005.61439-5-monego@posteo.net
State Accepted
Headers show
Series [bug#51396,1/7] gnu: python-aws-sam-translator: Update to 1.39.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Oct. 25, 2021, 7:50 p.m. UTC
awscli, botocore and boto3 work together and typically require matching
versions.

* gnu/packages/python-xyz.scm (python-botocore): Update to 1.22.2.
(python-boto3): Update to 1.19.2.
[native-inputs]: Add python-pytest.
* gnu/packages/python-web.scm (awscli): Update to 1.21.2.
---
 gnu/packages/python-web.scm |  4 ++--
 gnu/packages/python-xyz.scm | 14 +++++++-------
 2 files changed, 9 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d1665b1de3..fed7a388df 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2848,14 +2848,14 @@  supports url redirection and retries, and also gzip and deflate decoding.")
   (package
     ;; Note: updating awscli typically requires updating botocore as well.
     (name "awscli")
-    (version "1.18.203")
+    (version "1.21.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri name version))
        (sha256
         (base32
-         "128zg24961j8nmnq2dxqg6a7zwh3qgv87cmvclsdqwwih9nigxv9"))))
+         "13mnz414li0l5ph3wf160frfx46cynq8ws5ddmmlppc6rld6im02"))))
     (build-system python-build-system)
     (arguments
      ;; FIXME: The 'pypi' release does not contain tests.
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eb9fcc310d..3ad05effaf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13471,14 +13471,14 @@  This software is unmaintained, and new projects should use @code{boto3} instead.
   ;; are compatible.
   (package
     (name "python-botocore")
-    (version "1.19.22")
+    (version "1.22.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "botocore" version))
        (sha256
         (base32
-         "0iim86x7c6hqmvd61ygz6x6x9glnsfbnyzv2y67qjdcdx8jpkmw7"))))
+         "14qia74g5dx2p7yivaxdj6dwkpcf3skcywqmb6k3m12bkbkn04q1"))))
     (build-system python-build-system)
     (arguments
      ;; FIXME: Many tests are failing.
@@ -13499,7 +13499,7 @@  interface to the Amazon Web Services (AWS) API.")
 (define-public python-boto3
   (package
     (name "python-boto3")
-    (version "1.16.22")
+    (version "1.19.2")
     (home-page "https://github.com/boto/boto3")
     (source (origin
               (method git-fetch)
@@ -13507,19 +13507,19 @@  interface to the Amazon Web Services (AWS) API.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0h20hgl4yfl58g75qhb6ibrdmzn47md3srgar7hask14cjmfhfy3"))))
+                "1mms4hazh0pcg104nqhclllh8lphd5igi1plz8x9v0y7jj4skjdp"))))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'delete-network-tests
            ;; Deleting integration tests because they are trying to connect to AWS.
 	   (lambda _
-	     (delete-file-recursively "tests/integration")
-	     #t)))))
+	     (delete-file-recursively "tests/integration"))))))
     (build-system python-build-system)
     (native-inputs
      `(("python-nose" ,python-nose)
-       ("python-mock" ,python-mock)))
+       ("python-mock" ,python-mock)
+       ("python-pytest" ,python-pytest)))
     (propagated-inputs
      `(("python-botocore" ,python-botocore)
        ("python-jmespath" ,python-jmespath)