diff mbox series

[bug#51389] gnu: lttng-tools: Patch default man path.

Message ID 20211025161843.7507-1-olivier.dion@polymtl.ca
State Accepted
Headers show
Series [bug#51389] gnu: lttng-tools: Patch default man path. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Olivier Dion Oct. 25, 2021, 4:18 p.m. UTC
* gnu/packages/linux.scm (lttng-tools)
[arguments]: Add 'patch-default-man-path after 'unpack phase.
---
 gnu/packages/linux.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès Oct. 27, 2021, 10:29 p.m. UTC | #1
Hi,

Olivier Dion <olivier.dion@polymtl.ca> skribis:

> * gnu/packages/linux.scm (lttng-tools)
> [arguments]: Add 'patch-default-man-path after 'unpack phase.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 61ec6d8657..3b4da16d78 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8167,7 +8167,12 @@  (define-public lttng-tools
          (add-before 'configure 'set-environment-variables
            (lambda _
              (setenv "HOME" "/tmp")
-             (setenv "LTTNG_HOME" "/tmp"))))))
+             (setenv "LTTNG_HOME" "/tmp")))
+         ;; We don't put (which "man") here because LTTng uses execlp.
+         (add-after 'unpack 'patch-default-man-path
+           (lambda _
+             (substitute* "src/common/defaults.h"
+               (("/usr/bin/man") "man")))))))
     ;; NOTE - Users have to install python-3 in their profile to use the
     ;; bindings.  We don't put it in the inputs, because the rest of the tools
     ;; can work without it.