diff mbox series

[bug#51376,core-updates-frozen] gnu: mariadb: Don’t run tests in parallel on ppc64le targets.

Message ID 20211024150030.110739-1-bauermann@kolabnow.com
State Accepted
Headers show
Series [bug#51376,core-updates-frozen] gnu: mariadb: Don’t run tests in parallel on ppc64le targets. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thiago Jung Bauermann Oct. 24, 2021, 3 p.m. UTC
* gnu/packages/databases.scm (mariadb)[arguments]: Add ‘#:parallel-tests?’.
---

Hello,

This patch together with the glib one from https://issues.guix.gnu.org/51165
allows me to successfully run `guix pull` on powerpc64le-linux.

It doesn’t change the package derivation on non-ppc64le targets.

Thanks,
Thiago.

 gnu/packages/databases.scm | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Efraim Flashner Oct. 25, 2021, 11:12 a.m. UTC | #1
On Sun, Oct 24, 2021 at 12:00:30PM -0300, Thiago Jung Bauermann via Guix-patches via wrote:
> * gnu/packages/databases.scm (mariadb)[arguments]: Add ‘#:parallel-tests?’.
> ---
> 
> Hello,
> 
> This patch together with the glib one from https://issues.guix.gnu.org/51165
> allows me to successfully run `guix pull` on powerpc64le-linux.
> 
> It doesn’t change the package derivation on non-ppc64le targets.
> 
> Thanks,
> Thiago.

I ran into similar issues on some of my other machines too, I'll see if
this helps with them too.

Patch pushed!
Thiago Jung Bauermann Oct. 25, 2021, 5:49 p.m. UTC | #2
Hello,

Em segunda-feira, 25 de outubro de 2021, às 08:12:43 -03, Efraim Flashner 
escreveu:
> On Sun, Oct 24, 2021 at 12:00:30PM -0300, Thiago Jung Bauermann via Guix-
patches via wrote:
> > This patch together with the glib one from
> > https://issues.guix.gnu.org/51165 allows me to successfully run `guix
> > pull` on powerpc64le-linux.
> > 
> > It doesn’t change the package derivation on non-ppc64le targets.
> > 
> I ran into similar issues on some of my other machines too, I'll see if
> this helps with them too.

Good luck. :-)

> Patch pushed!

That was quick. Thank you very much!
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index daa47e7c59fb..74ad72a9b20a 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -831,6 +831,10 @@  Language.")
                         "/share/mysql/support-files")
          "-DINSTALL_MYSQLSHAREDIR=share/mysql"
          "-DINSTALL_SHAREDIR=share")
+       ;; The testsuite has spurious failures (mostly timeouts) if run in
+       ;; parallel on Guix CI’s ppc64le VM. It appears that the I/O load is
+       ;; too high for it to handle.
+       #:parallel-tests? ,(not (target-ppc64le?))
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'adjust-output-references