diff mbox series

[bug#51323,1/3] Add xfce4-dev-tools

Message ID 20211021220641.4400-1-GNUtoo@cyberdimension.org
State Accepted
Headers show
Series [bug#51323,1/3] Add xfce4-dev-tools | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Denis 'GNUtoo' Carikli Oct. 21, 2021, 10:06 p.m. UTC
This is now needed to build newer lightdm-gtk-greeter versions

* gnu/packages/xfce.scm (xfce4-dev-tools): New variable.

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
 gnu/packages/xfce.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Ludovic Courtès Oct. 27, 2021, 10:38 p.m. UTC | #1
Hi,

Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> skribis:

> This is now needed to build newer lightdm-gtk-greeter versions
>
> * gnu/packages/xfce.scm (xfce4-dev-tools): New variable.
>
> Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>

[...]

> This also fixes the build. Before configure failed with
> the following error:
>     checking for exo-csource... no
>     configure: error: in `/tmp/guix-build-lightdm-gtk-greeter-2.0.7.drv-0/lightdm-gtk-greeter-2.0.7':
>     configure: error: exo-csource not installed
>
> * gnu/packages/display-managers.scm (lightdm): update to 2.0.8
>
> Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>

[...]

> The bash-minimal dependency is required by the wrap-program,
> and guix lint suggests to add it in the inputs.
>
> * gnu/packages/display-managers.scm (lightdm): add bash-minimal dependency
>
> Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>

Applied all three patches.  I removed the ‘Signed-off-by’: by convention
we keep it for the person who applies the patch.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index c653b23a91..c279ac9355 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -2130,3 +2130,28 @@  (define-public xfce4-weather-plugin
 local weather in the panel, using forecast data provided by the
 @uref{https://met.no, Norwegian Meteorological Institute}.")
     (license gpl2+)))
+
+(define-public xfce4-dev-tools
+  (package
+    (name "xfce4-dev-tools")
+    (version "4.17.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://archive.xfce.org/src/xfce/"
+                                  "xfce4-dev-tools/" (version-major+minor version) "/"
+                                  "xfce4-dev-tools-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1iwkqj96x2s7fk4srg1pymvsiwb2rn6vvhy6hrmnc3hl1vqw2d6k"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("glib" ,glib)))
+    (home-page "https://docs.xfce.org/xfce/xfce4-dev-tools/")
+    (synopsis "Xfce developer tools")
+    (description
+     "The Xfce development tools are a collection of tools and macros for Xfce
+developers and people that want to build Xfce from Git In addition it contains
+the Xfce developer's handbook.")
+    (license gpl2+)))