diff mbox series

[bug#51306] gnu: docker-compose: Update to 1.29.2

Message ID 20211020145945.25793-1-olivier.dion@polymtl.ca
State Accepted
Headers show
Series [bug#51306] gnu: docker-compose: Update to 1.29.2 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Olivier Dion Oct. 20, 2021, 2:59 p.m. UTC
* gnu/packages/docker.scm (docker-compose): Update to 1.29.2.
---
 gnu/packages/docker.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès Oct. 27, 2021, 10:41 p.m. UTC | #1
Olivier Dion <olivier.dion@polymtl.ca> skribis:

> * gnu/packages/docker.scm (docker-compose): Update to 1.29.2.

Applied, thanks!

Ludo’.
Olivier Dion Oct. 28, 2021, 12:46 a.m. UTC | #2
On Thu, 28 Oct 2021, Ludovic Courtès <ludo@gnu.org> wrote:
> Olivier Dion <olivier.dion@polymtl.ca> skribis:
>
>> * gnu/packages/docker.scm (docker-compose): Update to 1.29.2.
>
> Applied, thanks!
>
> Ludo’.

Note that I just tested, and python-dotenv is missing.  After adding it,
Pypi docker version is 3 major versions too old for docker-compose.
Even after bumping it, there's also many other nightmares with
pkg_resources throwing `DistributionNotFound`.

There's probably many things to fixe and I think it would be best to
revert this patch.

Sorry for the inconvenience.

Regards,  
Olivier
Ludovic Courtès Oct. 30, 2021, 2:01 p.m. UTC | #3
Hi,

Olivier Dion <olivier.dion@polymtl.ca> skribis:

> On Thu, 28 Oct 2021, Ludovic Courtès <ludo@gnu.org> wrote:
>> Olivier Dion <olivier.dion@polymtl.ca> skribis:
>>
>>> * gnu/packages/docker.scm (docker-compose): Update to 1.29.2.
>>
>> Applied, thanks!
>>
>> Ludo’.
>
> Note that I just tested, and python-dotenv is missing.  After adding it,
> Pypi docker version is 3 major versions too old for docker-compose.
> Even after bumping it, there's also many other nightmares with
> pkg_resources throwing `DistributionNotFound`.

Oh, too bad this isn’t caught at build time.

> There's probably many things to fixe and I think it would be best to
> revert this patch.

OK, done (will push shortly).

Ludo’.
Olivier Dion Oct. 30, 2021, 3:30 p.m. UTC | #4
On Sat, 30 Oct 2021, Ludovic Courtès <ludo@gnu.org> wrote:
> Hi,
>
> Olivier Dion <olivier.dion@polymtl.ca> skribis:
>
>> On Thu, 28 Oct 2021, Ludovic Courtès <ludo@gnu.org> wrote:
>>> Olivier Dion <olivier.dion@polymtl.ca> skribis:
>>>
>>>> * gnu/packages/docker.scm (docker-compose): Update to 1.29.2.
>>>
>>> Applied, thanks!
>>>
>>> Ludo’.
>>
>> Note that I just tested, and python-dotenv is missing.  After adding it,
>> Pypi docker version is 3 major versions too old for docker-compose.
>> Even after bumping it, there's also many other nightmares with
>> pkg_resources throwing `DistributionNotFound`.
>
> Oh, too bad this isn’t caught at build time.
>
>> There's probably many things to fixe and I think it would be best to
>> revert this patch.
>
> OK, done (will push shortly).

No need.  See ad39268cdf075f4c4eeb87ed78ce46ca6f817675 :-)
>
> Ludo’.
>
diff mbox series

Patch

diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 8bac1b89ce..9ab9e86c21 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
 ;;; Copyright © 2020 Jesse Dowell <jessedowell@gmail.com>
 ;;; Copyright © 2021 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2021 Olivier Dion <olivier.dion@polymtl.ca>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -106,14 +107,14 @@  (define-public python-dockerpty
 (define-public docker-compose
   (package
     (name "docker-compose")
-    (version "1.25.4")
+    (version "1.29.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "docker-compose" version))
        (sha256
         (base32
-         "1ww8ckpj3n5jdg63qvmiqx3gk0fsrnynnnqj17fppymbwjzf5fps"))))
+         "1dq9kfak61xx7chjrzmkvbw9mvj9008k7g8q7mwi4x133p9dk32c"))))
     (build-system python-build-system)
     ;; TODO: Tests require running Docker daemon.
     (arguments '(#:tests? #f))